Default value not working consistently

  • Profile Image
    adunbar2
    Asked on April 02, 2018 at 01:05 PM

    On nursing cap documentation submission form, when you click on my nursing cap portfolio (level1) is complete, portfolio status should automatically be YES. Sometimes it is defaulted sometimes it is not, I have to click on and off "my nursing cap portfolio (level1) is complete in order for it default. Why is it not working consistently? I am using internet explorer.

  • Profile Image
    BDAVID
    Answered on April 02, 2018 at 02:04 PM

    I believe that this is the form you are referring to: http://www.jotform.us/form/80516314944153

    What is the field in question? I could not see any field called "my nursing cap portfolio (level1)". Could you please share a screenshot to show us the field you are referring to? https://www.jotform.com/help/438-How-to-Post-Screenshots-to-Our-Support-Forum 

  • Profile Image
    adunbar2
    Answered on April 02, 2018 at 04:30 PM

    In order for nursing cap is complete to show, you must enter (1) in applying for level field. Then on Part A section you must have at least 7 points so you can just select the fields below. Then you should be able to see nursing cap is complete now

  • Profile Image
    BDAVID
    Answered on April 02, 2018 at 04:53 PM

    I just cloned your form, and located the field in question(which is located in page 4), and the reason why it shows up empty, is due to no default option being setup for that field:

    1522702339defaultoption.png

    Please go to advanced settings for that field, and setup the default option. Let us know if you have more questions.

  • Profile Image
    adunbar2
    Answered on April 02, 2018 at 05:32 PM

    I do not have defaults on that page. The default should be under Portfolio Complete Status

  • Profile Image
    BDAVID
    Answered on April 02, 2018 at 06:54 PM

    So, is the "Portfolio Complete Status" field the one in question? If that is correct, I just tested it, and the default option is still selected when meeting or not meeting the "show" condition:

    1522709310show.png

    Example:

    1522709392showfield.gif

    Same result with IE browser:

    1522709528ie.gif

    What IE version are you using? Probably you need to update it. I would suggest you to use a different browser, such as Chrome or Firefox.

  • Profile Image
    adunbar2
    Answered on April 03, 2018 at 03:10 PM

    It is now working better when I removed the option of No in portfolio complete status. Will keep testing. Thank you.

  • Profile Image
    adunbar2
    Answered on April 03, 2018 at 04:02 PM

    I can reproduce it again after further testing. I am also on IE 11. I am not using Chrome as most of our computers in our organization only support IE

  • Profile Image
    BDAVID
    Answered on April 03, 2018 at 04:35 PM

    Are you referring to the same form? I just tested it, and the default options remains there:

    1522787715works.gif

  • Profile Image
    adunbar2
    Answered on April 03, 2018 at 05:02 PM

    Yes it seems to be sporadic. Anyway as a workaround I just made the fields unhidden and required so that if not defaulted the users can just click on it to indicate Yes or enter the email address. Thanks

  • Profile Image
    BDAVID
    Answered on April 03, 2018 at 06:07 PM

    Perfect, open a new thread if you need anything else, we will be glad to assist you.