Problems populating second form

  • Profile Image
    FnG1991
    Asked on June 27, 2019 at 10:10 AM

    Hi there,

    I have created two forms so I can users can save and continue. 

    The first form is a simple registration form and the second form is a full appication. I have set up the URL to continue the session but I want the name and email to be carried forward to the new form but the name  only appears in the first name text box on the second form.

    I have tried various things, following examples of other users having same problem but it isn't working for me.

    Can you help?

  • Profile Image
    Richie_P
    Answered on June 27, 2019 at 11:42 AM

    You may use URL parameters to pass the data from one form to another.

    Guide:https://www.jotform.com/help/351-How-to-Automatically-Pass-Form-Data-to-Another-Form

    I have checked your form and you may use this URL parameter:

    https://www.jotformeu.com/form/91744107617357?8name[first]={name:first}&8name[last]={name:last}&email={email}

    You may add the URL parameter in your Thank you page or autoresponder.

    Please give it a try and let us know if the issue still remains.

  • Profile Image
    FnG1991
    Answered on June 27, 2019 at 12:03 PM

    Do I not need to keep ?session={email}  as part of the URL so people can save and continue?

  • Profile Image
    FnG1991
    Answered on June 27, 2019 at 12:07 PM

    Update 

    Unfortunately this didn't make any difference. The full name only appears in the first name box of the second form.

    Any other suggestions?

  • Profile Image
    Victoria_K
    Answered on June 27, 2019 at 01:14 PM

    Hello,

    The link on Thank You page was broken for your form https://www.jotform.com/91763402529358 

    I have fixed it for you. Please test your form now to see how it goes.

  • Profile Image
    FnG1991
    Answered on June 27, 2019 at 01:51 PM

    Problem still exists I’m afraid. Full name appears in first name textbox on second form.

  • Profile Image
    Richie_P
    Answered on June 27, 2019 at 02:00 PM

    The URL parameter is working correctly at my end.

    https://form.jotformeu.com/91744107617357?session={email}&8name[first]={name:first}&8name[last]={name:last}&email={email}

    Can you please try redirecting through the Thank you page?

    Can you please try clearing your browser's cache and let us know if the issue still remains?

  • Profile Image
    FnG1991
    Answered on June 27, 2019 at 04:19 PM

    Hi there,


    Afraid the same problem exists using Google Chrome. I tried safari but the name didn't carry forward at all, although the email did.

    Any further suggestions? It's only a minor issue, really but would love to get right.

    Thanks in advance

  • Profile Image
    FnG1991
    Answered on June 27, 2019 at 04:23 PM

    Ah it seems to have worked now!!!!


    Thanks so much

  • Profile Image
    Victoria_K
    Answered on June 27, 2019 at 04:34 PM

    That is great to know! If you encounter any other difficulty, please get back to us.