Thank You page does not show up on the embedded form after submit

  • Profile Image
    kaiwanner
    Asked on July 26, 2019 at 08:08 AM

    I have an Instapage which contains a sign-up for events. After a sign-up (as soon as someone hits the sign-up button) we would like a Jotform to open with a thank-you-notice. 

    We implemented the Jotform into the page via IFrame, yet when we test it by signing up, the form does not appear. There is simply a blank page. 

    Our programmers have had a look at the CSS/ Backend and it seems the form is implemented correctly, but the html simply appears to be empty for no reason. 

    Have you heard of this problem before or are there any tipps you can give me to make it work? 

    I don't know if you can see my forms, but the form in question is called SAP Events, in case you want to check it out. 

    Thank you!

  • Profile Image
    Vanessa_T
    Answered on July 26, 2019 at 09:57 AM

    I've checked your site and was able to see a Jotform on your page, is this the form you are referring to?

    15641493661.png

    Let us know if you're still having issues. You may also want to check out this guide when embedding using the iFrame code.

    Getting-the-Form-iFrame-Code

  • Profile Image
    kaiwanner
    Answered on July 26, 2019 at 10:06 AM

    Hi, 


    yes, that is the form. But part of it should be a thank-you page that opens after the user signs up for the Event. Right now a blank, white page opens when you sign up. Have we created the form wrong or missed something? 


    Thank you

  • Profile Image
    Vanessa_T
    Answered on July 26, 2019 at 11:39 AM

    I did a test submission on your embedded form and was able to see an error after submission.

    1564155380Screen Shot 2019-07-26 at 11.3

    1564155392Screen Shot 2019-07-26 at 11.3

    It seems that there's a conflict between the scripts on your form and the scripts on the page. You may try adding the noConflict() function to your form, here is a link with more info about it: https://api.jquery.com/jquery.noconflict

    If the issue still persist, please make sure that the exact iFrame embed code provided by following this guide is used, without any alterations.