Form is not fully showing up when embedded

  • Profile Image
    MethowHousingTrust
    Asked on August 22, 2019 at 06:17 PM

    Hello, I'm having a problem with the display of my JotForm. It only displays part of it, rather than the full form on our squarespace page. This doesn't allow it to be completed.... How do I edit this?

    Also, how to I make a link in the form open up in a new window rather than in the form frame?
  • Profile Image
    JohnRex
    Answered on August 22, 2019 at 07:06 PM

    I have tried accessing the link you provided and was not able to replicate the issue. I am able to view the whole form:

    15665148371937253.png

    I can see that you embedded the form using its iframe code. You can adjust the form's height by modifying the height property in the iframe code like the one below:

    15665150401937253 2.png

    Also, how to I make a link in the form open up in a new window rather than in the form frame?

    I have moved this concern to a separate thread. You can view my response here:

    https://www.jotform.com/answers/1937300

  • Profile Image
    MethowHousingTrust
    Answered on August 26, 2019 at 12:38 PM

    Thank you I will try that. Just to clarify, the issue is when I navigate to the eligibility page... If I refresh the page the issue goes away. But I see this being an issue for someone who does not know to refresh the page.... I will try adjusting the height and will let you know if this takes care of the problem.

  • Profile Image
    JohnRex
    Answered on August 26, 2019 at 01:07 PM

    May we know if you're viewing it on mobile? The Jotform branding might have blocked some fields in the bottom when the page is viewed on devices with smaller screens. However, adjusting the iframe's height can resolve it.

    Please try that and let us know how it goes.

  • Profile Image
    MethowHousingTrust
    Answered on August 26, 2019 at 01:10 PM

    I was able to adjust the height and I am no longer having this issue. thank you!

  • Profile Image
    MethowHousingTrust
    Answered on August 26, 2019 at 01:14 PM

    The issue was only identified when viewed via desktop. I'd not tried viewing it via mobile. I just did view it via mobile and it appeared correctly.

  • Profile Image
    JohnRex
    Answered on August 26, 2019 at 01:40 PM

    Good to know that the issue has been resolved. I think we can now close this thread.

    Should you have further concerns, please let us know by posting it here.