SendGrid Integration is not sending data to the selected list.

  • Profile Image
    psicotrec
    Asked on January 04, 2020 at 10:40 PM

    I just configure a form with the SendGrid integration and the submissions don't appear in my SendGrid account.

    1578195899Captura de Pantalla 2020-01-04

    Screenshot
  • Profile Image
    BDAVID
    Answered on January 05, 2020 at 12:02 AM

    Your form appears to be correctly integrated. Please try generating a new API Key, and integrate back gain: https://www.jotform.com/help/557-How-to-Integrate-Your-Form-With-SendGrid

  • Profile Image
    psicotrec
    Answered on January 05, 2020 at 11:41 AM

    I delete the API Key from SendGrid, create a new one, configured again, tried again, wait, and the problem persists. The submissions don't appear in my SendGrid account.

  • Profile Image
    VincentJay
    Answered on January 05, 2020 at 12:47 PM

    I checked the integration and it looks good on my end. I cleared your form cache on our server. After that, I submitted a test submission to your form, could you please check if you receive it or not?

    Also, please check the SendGrid site and try to contact their support. Let them know too that you're getting submission to JotForm. 

    Let us know how it goes. Thank you.

  • Profile Image
    psicotrec
    Answered on January 05, 2020 at 01:06 PM

    Hello VincentJay,

    I received your submission in my JotForms account but not in my SendGrid account. Also, I just create a ticket in SendGrid explaining the issue. 

  • Profile Image
    jonathan
    Answered on January 05, 2020 at 03:07 PM

    I have test SendGrid integration using my test account, and it appears to be working properly at this time.

    I was able to see the test submission added to my test SendGrid account Email Contact list.

    1578254711zzz 2020-01-06 04.01.34.png


    In SendGrid

    1578254734zzz 2020-01-06 04.00.09.png


    1578254747zzz 2020-01-06 04.03.15.png


    Please check also in your SendGrid account to make sure the Contact list is active and available.

    Let us know if issue persist.

  • Profile Image
    psicotrec
    Answered on January 05, 2020 at 08:26 PM

    After I read your message Jonathan I proceed to clone my form, created a new Sendgrid API, Sendgrid list, and configure again the integration with ONLY the NAME and EMAIL field:

    1578273253Captura de Pantalla 2020-01-05

    And it was working:

    1578273336Captura de Pantalla 2020-01-05



    Then, I proceed to clone the form again but configuring the integration with my "Custom Fields":

    1578273909Captura de Pantalla 2020-01-05

    1578273594Captura de Pantalla 2020-01-05


    And it was not working again. After that, I edit the integration removing the "Custom Fields" like in the first case. And it was not working either. That's super weird. Thanks for the feedback.

  • Profile Image
    JohnRex
    Answered on January 05, 2020 at 10:07 PM

    Let me conduct some tests for this integration and try to replicate the issue on my end.

    I will get back to you on this thread shortly.

  • Profile Image
    psicotrec
    Answered on January 06, 2020 at 12:04 PM

    FYI

    1578330210Captura de Pantalla 2020-01-06

  • Profile Image
    BDAVID
    Answered on January 06, 2020 at 01:18 PM

    Thanks for sharing, I'll check with my colleague if we have any updates. You will be notified here.

  • Profile Image
    JohnRex
    Answered on January 07, 2020 at 01:51 AM

    Apologies for the delayed response.

    I'm able to replicate the issue on my end. I have made a few test submissions using a FULL ACCESS API Key but the data is not being sent to the CONTACT LIST in SENDGRID. It also throws a console error 403-Forbidden:

    15783795922100635.png

    I suspect this has something to do with SendGrid's API KEY permissions using their v3 API. Please try reaching them out regarding this issue.

    I have searched that the said issue is being experienced by other users:

    https://github.com/sendgrid/sendgrid-nodejs/issues/957


  • Profile Image
    psicotrec
    Answered on January 08, 2020 at 12:39 AM

    Hello JohnRex:

    I transmitted your message to SendGrind and they answered this:

    1578461864DBE11C47-DA59-41BE-B5F5-A02B95

  • Profile Image
    ashwin_d
    Answered on January 08, 2020 at 05:48 AM

    I am escalating this to our backend team to check what API end point is being used in the integration. 

    We will get back to you as soon as we have any update on this. 

  • Profile Image
    psicotrec
    Answered on January 10, 2020 at 12:42 PM

    Hello. Any updates?

  • Profile Image
    IvayloK
    Answered on January 10, 2020 at 02:15 PM

    Unfortunately, there are not any updates yet.

    I sent a follow up to the backend team. We will immediately let you know, if we have any updates.

  • Profile Image
    kazim
    Answered on January 14, 2020 at 05:12 AM

    Hello, 

    This issue was related to mapping Sendgrid's custom date field to a form field. And, this issue has been resolved now.

    If you still encounter any issue, please do not hesitate to contact us. 

    Regards


  • Profile Image
    psicotrec
    Answered on January 16, 2020 at 11:03 AM

    Now it's working perfectly. Thanks for the support.