Submission view is empty and not receiving notification with edit link

  • Profile Image
    lev.z
    Asked on September 16, 2020 at 06:54 AM

    Hi,

    I cloned the form. Submitted the answers. Redirected to Thank you page.

    But the are some issues:

    1. The submissions view is empty.

    2. I also didn't receive the NOTIFICATION WITH EDIT LINK

    Please assist.

    Lev



    This is a re-post of a comment on A General Approach on Building an Approval Process Workflow

  • Profile Image
    Sam_G
    Answered on September 16, 2020 at 08:05 AM

    Hi Lev,

    Thank you for contacting Support.

    May we ask for the form URL in question to check?
    https://www.jotform.com/help/401-Where-to-Find-My-Form-URL

    You can also check your submissions through the Submission tab or Inbox.

    1600257868_5f61ff4cb4e89_9.16 submission

    Related guide: https://www.jotform.com/help/269-How-to-View-Form-Submissions

    https://www.jotform.com/help/327-Viewing-Submissions-via-Inbox-and-Submissions-Panel


  • Profile Image
    lev.z
    Answered on September 16, 2020 at 12:04 PM

    Hi,

    UPDATE: I can view now the form @submissions, but I still didn't receive the NOTIFICATION WITH EDIT LINK 

    Here is the form: https://form.jotform.com/202592808548464

    Btw, I checked the spam folder also.


    Lev

  • Profile Image
    Kiran
    Answered on September 16, 2020 at 01:53 PM

    I see that there are conditions set on the form to send the email notification/autoresponder.

    1600278536_5f62500862e30_undefined

    Please note that the emails with conditions shall only be sent only if the rules are passed in the condition. I have tried sending a test submission to your form and see that the notification is not triggered.

    The conditions #3 and #4 are displaying EMAIL_NOT_FOUND which could be causing the issue and when the condition is edited, it is displaying with the notification. Also, if you want the email notification to be sent to every submission and edited submission, it is not required to setup a condition for the email. You may disable the condition #2 and test the form again to see how it goes.

    Please get back to us if you need any further assistance. We will be happy to help.