My Jotform 'Application Form' won't completely load

  • Profile Image
    AcrossTheDivide
    Asked on February 08, 2021 at 05:33 PM

    The Jotform edit opens but I can't scroll or click on any links. This is on a new MacBook Pro. It all works on my iMac though. Any tips on what the problem might be?

    Thanks.

  • Profile Image
    Vick_W
    Answered on February 08, 2021 at 10:23 PM

    Hi there,

    Your form builder is working fine here as well. Could you please try a different browser?

    I've also noticed that the background image you are using in your form is 18.4 MB. This will affect your form loading speed greatly and could also be a reason why the form builder is not working on your end. Please use properly optimized images in your form. The smaller the page size the faster it will load.

    Let us know if you need further assistance.

    Thanks

  • Profile Image
    AcrossTheDivide
    Answered on February 09, 2021 at 02:15 AM

    I have optimised the images to below 1MB. A few of my forms are still locking up when I go in to the editor.

    Thanks for looking in to this for me.


  • Profile Image
    Vick_W
    Answered on February 09, 2021 at 03:22 AM

    Hi there,

    You can give us the form URLs and we will check them as well. Looking forward to your reply.

    Thanks

  • Profile Image
    AcrossTheDivide
    Answered on February 09, 2021 at 03:33 AM
    Here is the one with the main issue: https://form.jotform.co/73342871329864
    ...
  • Profile Image
    Sam_G
    Answered on February 09, 2021 at 04:34 AM

    Hi AcrossTheDivide,

    I have tested the form and it is loading as expected.

    1612863250_602257126b7dc_

    Which browser are you using on your Macbook Pro?

    May we ask for the console logs error: https://www.jotform.com/help/453-how-to-get-a-console-report-from-most-common-browsers

    We will wait for your response.

  • Profile Image
    AcrossTheDivide
    Answered on February 10, 2021 at 10:11 PM
    I use Safari and the console log error won’t come up as the page seems to be locked up.
    Thanks.
    ...
  • Profile Image
    Vick_W
    Answered on February 10, 2021 at 11:34 PM

    Hi there,

    The form builder seems to be working normally as you can see below. Although my internet is slow today but still it loaded properly.

    1613017914_6024b33a9d7ad_1test.gif

    You mentioned that you are currently using Safari browser, could you please check it on a different browser?

    Looking forward to your reply.

    Thanks