Why did I lose my designs after reverting form back to the classic layout?

  • Profile Image
    eric733
    Asked on February 18, 2021 at 01:47 PM

    I was testing the single question feature versus all questions on one page and it did something strange to my original design. When I tried to revert back to a previous version, it completely threw the design out of whack! I have been working on this for a long time and would appreciate the assistance.

    --

    Eric

  • Profile Image
    Gustavo_H
    Answered on February 18, 2021 at 06:14 PM

    Hi, Eric. I hope you are having a great day.


    Unfortunately, there is no other way to revert to a previous version besides the Revision History. Have you applied CSS code to your form, and you lost it after reverting back? I test switching my form with CSS code to card layout and then back to the classic layout, and I did not lose the CSS code. If this happened to you, please, let us know, and we will alert our developers about it.


    Best regards, 🌟

  • Profile Image
    JPHillside
    Answered on February 19, 2021 at 08:51 AM

    Thank you for your reply. Before the issue had happened, I had done a bunch of different design things such as going back and forth to CSS expert design mode. When I tried to view the form in single question format and then reverted back to full form format, that is when the issue occurred. It seemed to strip the original design elements that made the form look nice, left aligned everything and made basic fonts with all questions showing as bulleted. Using the undo history in the design mode was not working no matter what. It would show that everything was fine but then when I went to actually view the preview or live version, all the elements were "stripped" from the design.

    I did come across a fix, however. When I exited the design mode and went to the page where forms created were listed, I selected the options in the menu on the far right and browsed the design history there. From that area I was able to restore my form back to the original before the issues took place.

    Thanks again for your reply.

    --

    Eric

  • Profile Image
    Alexander_G
    Answered on February 19, 2021 at 10:36 AM

    Hi Eric,

    Thank you for your reply.


    Please, confirm that your issue is solved now.


    Thanks,

    Alex

  • Profile Image
    JPHillside
    Answered on February 19, 2021 at 10:40 AM

    My issue is solved. Thanks