Notification emails are not received

  • Profile Image
    Cartercleaning
    Asked on February 25, 2021 at 03:41 AM

    For my form I am not seeing the submissions in my inbox nor my emails. My form is on my website www.cartercleaningservice.com. I tested and completed form but I get a new email titled “new submission on work with us” to my personal email cartertausha@gmail.com. Can’t figure this out. Please assist. And the thank you page is not one set up in my form.

  • Profile Image
    Lorenz_A
    Answered on February 25, 2021 at 06:54 AM

    Hi there,

    To clarify, you are not receiving the submissions via email only, right?

    I've checked your email notification, and it is currently configured to send the submission email to tausha.carter@cartercleaningservice.com.

    I've checked our email logs, and there was no email notification sent to cartertausha@gmail.com that was submitted through your form https://form.jotform.com/92675117844162, and that email is currently not included on your email notification.

    Kindly check your email tausha.carter@cartercleaningservice.com, it should have the notification email of the submission. You may also look in the spam folder if the email notification is nowhere to be found in the inbox.

    Let us know if you need any further assistance.

  • Profile Image
    Cartercleaning
    Answered on February 25, 2021 at 07:00 AM
    This is what was received in my personal email. Nothing ever came to business email. I tried twice. Yesterday has two people say they applied for position which I never received form. [Image.jpeg]
    Best regards,
    Tausha Carter
    ________________________________
    ...
  • Profile Image
    Lorenz_A
    Answered on February 25, 2021 at 08:32 AM

    Hi there,

    The screenshot you posted didn't go through, kindly upload the image once more on this link https://www.jotform.com/answers/2924538 by following the guide below.

    Guide: https://www.jotform.com/help/438-how-to-post-screenshots-to-our-support-forum

    I've checked our email logs and it seems there were really no emails that were sent to both parties. I cloned your form but I was not able to replicate the issue, notification emails were sent as expected.

    Can you please try to resubmit the submissions through the edit mode?

    See the image below.

    1614259640_6037a5b87bacc_How to Edit Sub

    Related guide: https://www.jotform.com/help/325-how-to-edit-submissions-made-on-your-forms

    If the issue still persists, kindly recreate your notification emails to see if that'll help.

    I have cleared your form's cache as a precaution.

    Please do let us know how it goes.