What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Forms not loading/submitting correctly

    Asked by thebrucecook on March 11, 2014 at 04:15 PM

    I had a guest try to fill in and submit my form using an iphone and they couldn't do it. I tried it on my iphone and noticed the form loaded okay, but the submit button ("I Agree" on this particular form) is missing. Are these forms set up to work on mobile devices? If so, how do I fix?

    Then, another guest left me a VM that they couldn't get the form to work. I haven't talked to them so don't know if it was on a computer browser or mobile device. I decided to check my own website and found a problem when I tried to load the page. The page would first load without the form and it would take me several attempts to reload the page before the form would actually load. I'm was doing this on Google Chrome browser running MAC OS Maverick. The same thing happened when I tried it on Safari Browser, I had to load the page three times to get the form to show up, then oddly, it showed up with only one of the two changes I just made to the form on your site.

    Page URL:
    http://laketravistreelodge.com/guestagreement

    problem Mobile check site
  • Profile Image
    JotForm Support

    Answered by BDAVID on March 11, 2014 at 07:02 PM

    Hi, you nee to delete the highlighted line of code, since it is  conflicting:

    I would recommend you to remove all the embedded code of the form, then get and copy the iFrame code of the form again into the web page.

  • Profile Image

    Answered by thebrucecook on March 11, 2014 at 08:20 PM
    I'm confused. This is the only html code I added to my website:
    src="//form.jotform.us/jsform/30848556014152">
    Is this code from the html on my website or is this some code jotform
    uses? I've never worked with code on jotform before and do not know how.
    Also, up until very recently, the form has worked just fine on my
    website, so why the change now?
    JotForm Support Forum wrote:
    ...
  • Profile Image
    JotForm Support

    Answered by jonathan on March 11, 2014 at 09:31 PM

    Hi,

    The initial embed code that you used is the script code version which is the default code embed. You can read for more details here -Adding-a-Form-to-a-Web-Page

    Since there also other scripts existing in your website where the form was embedded, script conflict is happening between those in the form and in your website. The script conflict is the reason why form is not loading/submitting as normal.

    As suggested already by our colleauge, you should try also re-embedding using the iframe code embed version. Use this guide https://www.jotform.com/help/148-Getting-the-Form-iFrame-Code

    When iframe embed is used, it eliminates the script conflict. So, the form in your website should work properly.

    Please try this and inform us if issue still persist.

    Thanks.