Jotform PDF viewer - "Missing Parameters"

  • Profile Image
    HuttonSafetyGroup
    Asked on October 27, 2021 at 11:20 AM

    Hi, we have a client that accesses their work orders, which are Jotform PDFs, through a dashboard which we built for them in Google Data Studio.

    All the dashboard does is display the links to the PDF viewer for each work order and shows some of the form fields in a table https://datastudio.google.com/reporting/3880ab60-f8fd-4b43-b93d-6b8924c6ebd8/page/6ZvFC . The "View" links at the right hand side take you to the PDF viewer, which is where the client sees the error message.

    When they click on the link to view the PDFs they are getting the error message in the attached screenshot: "Missing parameters."

    The client sees this error message regardless of which "View" link they cIick on. I am unable to replicate the client's issue, even when going into an incognito window in Chrome.

    Do you know what can cause this missing parameters issue?

    Thanks.


  • Profile Image
    Kat
    Answered on October 27, 2021 at 12:57 PM

    Hi there,

    Happy to help!

    To clarify: is this link sent to your form respondents or is this data compiled in several PDFs?

    In visiting the link above, I am unable to replicate the issue as well. Is this client experiencing it with all of the View links or just a few in particular? If so, which ones?

    I have gone ahead and cleared your form caches: could your client try again and let us know if the issue persists?

    Thank you!

  • Profile Image
    HuttonSafetyGroup
    Answered on November 03, 2021 at 12:44 PM

    Hi,

    The links leading to an error page are just jotform PDF links:

    https://www.jotform.com/pdf-editor/view/211104538779055/5110263068133326806

    Our client is still experiencing the issue with every PDF link.

    Can you reach out to the developers regarding cause of the missing parameters error message?

    Do you know of any issues that cause the Jotform PDF viewer to display a "missing parameters" message, such as browser/device/operating system?



  • Profile Image
    Kat
    Answered on November 03, 2021 at 02:14 PM

    Hi again,

    Thank you for the links: I can see that the issue is with the viewing links there.

    I am still unable to replicate the issue in the Chrome browser:

    1635961665_6182cb41b3994_

    "Missing parameters" could be due to several outside factors, especially if it is just one client experiencing it and we cannot replicate the issue, it could be a browser issue with your client's browser in particular. Before escalating, would you client be able to take a screenshot of their browser's Console Log Report and then could you upload it here for us please? Here's how-to-get-a-console-report-from-most-common-browsers/

    We look forward to your response!