What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Bug - Config List retains edited data in FireFox but not in Chrome

    Asked by swapna_summit on July 15, 2014 at 09:07 AM

    Hi

    I find the data entered in the configurable list widget sometimes is not showing while on Edit the form, a very few times i edited the form using email in chrome

    But most of the time the data entered could be seen while editing.

     

    I doubt whether it is due to this reason--when i edit the form using the link from email ,it actually opens in Mozilla-Firefox and the data in the configurable list widget actually takes a little bit more time than the other data that showed.so normally i copy that URL  and paste it suddenly to chrome before all the data in configurable list widget data came in Mozilla-Firefox.

    Any way i tried with out this problem and the data is coming without any error,

     

    But still need to concern the problem may happen again.

     I have cleared the cache also.

    Thanks,

    swapna.

    Page URL:
    http://submit.myjotform.com/form.php?formID=41892132684560&amp;sid=281<br/>237709665275922&amp;mode=edit

    Screenshot
    problem configurable list style size height font
  • Profile Image
    JotForm Support

    Answered by KadeJM on July 15, 2014 at 12:09 PM

    I think part of the problem is because the widget is contained within an iframe so its data seems to create a partial conflict when read inside of Chrome. As far as I know because of that I am under the impression this might be a factor in the reason why since the configurable list updates on the spot so when you edit this Chrome isn't recognizing it and therefore resets it when edited.

    When I had also done a separate test, I didn't have the same issue and each time I refreshed it after being edited it was fine regardless. I've cleared your form cache as I think that should help. However, if this is still an issue then please let us know.

     

    Here's my Screenshot Tests for Comparison:

    Here's what happened during my editing tests:

    And here's another Test with a Generated Edit Link:

    http://submit.jotform.us/form.php?formID=41953634934159&sid=281248881661576126&mode=edit

    I attempted this with one and also two Configurable Lists with the same result since I noticed you have many of these on your form. I think this is partly also the reason why you're not seeing an error. Anyways, I will try to figure this out more in case there is something wrong with it though so far I am not certain about that. Perhaps one of my colleagues might find something.

     

  • Profile Image

    Answered by swapna_summit  on July 15, 2014 at 12:53 PM

    thanks

  • Profile Image
    JotForm Support

    Answered by KadeJM on July 15, 2014 at 02:42 PM

    I decided to test this on your form some more and found the iframe which contains your Config List is working in FF whereas in Chrome it disregards it. I believe this is leading to the reset of your field after it's been edited or if the back button is used. I'm not quite sure of an exact reason why it works in FF and not Chrome like this just yet but if I am able to figure that part out then i'll let you know.

    In the meantime though, I am convinced that something is wrong so just to be safe I'm sending this over to our developers to have them take a deeper look into the matter. Because I think this should either be working in both browsers otherwise it wouldn't work at all in either of them to begin. As soon as something more is known then we'll update you here about it.

    I sent a submission test: 

    http://submit.myjotform.com/form.php?formID=41892132684560&sid=281257370661456397&mode=edit

     

    In my screenshots I was adding data then moving between pages on your form back and forth just to see what would happen and if the data would stay or not. It works in FF but not in Chrome. I thought originally maybe it was the length of your form and because of the use of multiple config lists though now I don't think that is the cause of the issue.

    Chrome:

     

    FireFox:

     

  • Profile Image
    JotForm Support

    Answered by kenneth on July 23, 2014 at 03:12 PM

    Hi @swapna_summit - I just want to inform you that we made a patch on this matter. I apologize that it took some time to put hands on this issue.

    Please test it from your end and let me know if the problem still persist so that we can further assist you.

    Thanks,
    Kenneth