What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    How can I open my saved forms?

    Asked by GT1974 on July 15, 2014 at 07:53 PM

    I go to my forms. I see my forms listed but cannot open them.

    saved My Forms cannot open
  • Profile Image
    JotForm Support

    Answered by pvvskk on July 15, 2014 at 08:19 PM

    Hi GT1974,

    I understand that you are experiencing issues in opening the saved forms from your account. This could be the issue with the forms or browser. Please follow the instructions provided in the document below to clear the cache and retry to open the forms.

    How-to-Clear-your-Form-Cache

    Please check if you are able to open them in a different browser. Please try clearing the cache of the browser by following the instructions provided in the document below :

    http://www.wikihow.com/Clear-Your-Browser's-Cache

    This should resolve the issue. If the issue still persists, please reply to this post with any error message that you are receiving while opening the forms. We are happy to assist you further.

    Regards,

    Kiran Kumar Polavarapu

     

  • Profile Image
    JotForm Support

    Answered by EltonCris on July 15, 2014 at 10:08 PM

    @GT1974 

    Performing a clear cache on your browser would help as suggested by my colleague.

    If you're still unable to edit the forms, I would suggest to try it on different browser. Your current browser might be defective or there might be some settings that is misconfigured resulting this issue.

    Thanks!