Creating Sign Document using the Demo file gets stuck in loading

  • Profile Image
    CL_Ward
    Asked on September 29, 2022 at 11:39 AM

    Anytime trying to create a signable document it doesn't load anything for me to add fields to the documnets.

  • Profile Image
    Eiron_O
    Answered on September 29, 2022 at 12:36 PM

    Hi Matt,

    Thanks for using Jotform. It would help us to understand the issue if you can provide the link to your form. I've cleared your form caches to refresh your forms. Also, you can send us a screenshot of the issue by following this guide.

    Once we have a better idea of what’s going on, we’ll be able to come up with a solution.


  • Profile Image
    CL_Ward
    Answered on September 29, 2022 at 03:01 PM

    https://www.jotform.com/sign/222694834982066


    Page just has loading icon on build page actual document never loads.

  • Profile Image
    Richard
    Answered on September 29, 2022 at 03:34 PM

    Hello Matt,

    Thanks for reaching out to Jotform Support. I'm sorry you're having difficulties with the Beta test of Signable Documents. I've tried to access the Sign Document URL you've provided and the same thing happened to me. After investigating it further, I confirmed that there's an error happening in the background which is why it gets stuck in loading.

    I went ahead and cleared your form cache to remove any minor bugs or glitches that could be the problem. Can you please try to create another Sign Document to test if it's still the same result?

    Give it a try and let us know how it goes.

  • Profile Image
    CL_Ward
    Answered on September 29, 2022 at 04:39 PM

    Same thing is happening when trying to create a new doc.

  • Profile Image
    Raymond
    Answered on September 29, 2022 at 05:22 PM

    Hi Matt,

    I'm sorry to hear about your experience. I was able to replicate the same issue on your link but after I created a new document, used the demo file, and everything seems to be working correctly. Can you try creating a new document again using the demo file but try it with a different browser this time? If the same thing happens again, please share with us the form link and we'll do some more testing to see what's going on.

    Keep us updated and let us know if you need any help.

  • Profile Image
    CL_Ward
    Answered on October 03, 2022 at 11:29 AM

    I tried to create a new doc using the demo sample document as well as a new doc using various of my own uploaded PDFs to no avail. Continuous loading icon and the document never populates. I've cleared the cache in Chrome and that doesn't help either. Only way I can get it to show the document is in Incognito mode.

  • Profile Image
    Carlo
    Answered on October 03, 2022 at 12:04 PM

    Hi CL_Ward,

    I'm sorry for the inconvenience this has caused you. Since you mentioned that the document is loading in Incognito mode, can you share with us the version of the browser that you are currently using? Also, can you also try creating a new document in a different browser to check if the issue still persist?

    If the issue continues, we'll create a performance ticket and forward it to our Developer team.

  • Profile Image
    CL_Ward
    Answered on October 03, 2022 at 03:23 PM

    I went through all of my extensions and the culprit was ExpressVPN. I disable it and the document loaded. Even though the VPN wasn't enabled it still wouldn't allow the page to load. Once extension completely disabled it loads just fine.