Notification: Signature image is broken

  • Profile Image
    Kazor
    Asked on September 30, 2022 at 11:44 AM

    Hi team!

    Signature image it's broken in email body

    I'd like to get some help to get the client's signature from the form they're filling out to also populate in the body email they get after submitting the form. I'm using a "fill in the blank" Form element along with a "signature" blank that seems to be tied to a widget. (I used that one because it lets my clients fill out the signature with a text as opposed to a "drawing" which most of the widgets use and I don't want that)


    I've also added the widget code in the email but doesn't seem to retrieve the image properly, any ideas? Or maybe another form element I should use?


    Please see the pictures below:


    This is the form element I'm using

    1664552293_63370d65d8549_


    This is how I embeded it into the email body this is the widget code: {input51}

    1664552399_63370dcf0bec7_

    But this is how it's coming out (The signature it's the broken picture)

    1664552478_63370e1e72582_

  • Profile Image
    Marvin
    Answered on September 30, 2022 at 12:37 PM

    Hi Chris,

    Thanks for reaching out to Jotform Support. I cloned your form and tested it to see if I could replicate the issue, but everything was working properly. Check out the screenshot below to see my results:

    1664555597_63371a4db75d8_Maybe the issue resolved itself. That happens sometimes. Also, I have cleared the form cache on our end to refresh it. You can clear your form cache as well on your end. We have a guide on How to Clear Your Form Cache? Can you try it again and see how it goes? If you run into the same problem again, let us know and we'll do some more testing to see what's going on.

    Give it a try and reach out again if you have any other questions.

  • Profile Image
    Kazor
    Answered on September 30, 2022 at 04:35 PM

    Hi Marvin!

    Thanks for your prompt response. We tried your suggestion a few times, we also tried checking the mail in our mobile phones but the picture still looks broken. any other ideas? Thank you!

  • Profile Image
    Marvin
    Answered on September 30, 2022 at 05:50 PM

    Hi Kazor,

    Thanks for getting back to us. Can we try to clone your form and the test it. Then let check and test your clone form if you will get broken image. This guide will help you on How to Clone an Existing Form From a URL. If the clone is working perferctly. You can use it or on the orginal form, you can try to remove the signature and re-add it again.

    Give it a try and reach out again if you have any other questions.

  • Profile Image
    Kazor
    Answered on October 03, 2022 at 10:18 AM

    Hi Marvin,

    We tried cloning the form and also removing the signature and re-adding it again but it didn't seem to work. We are still getting a broken image on the email.

  • Profile Image
    Waqas
    Answered on October 03, 2022 at 10:44 AM

    Hi Chris,

    Thanks for getting back to us. I cloned your form and tried to replicate the issue, but everything worked the way it should. Check out my results in the screencast below:

    1664807998_633af43e6b527_

    Can you please try to use incognito mode? If the issue still persists, can you please check the updates on your browser? Can you give it another try and let us know what happens? If you're still having the same problem, we'll do a more in-depth investigation and work on finding a solution.


  • Profile Image
    Kazor
    Answered on October 03, 2022 at 02:26 PM

    Hi,

    I just tested it and we're still getting the same problem.

  • Profile Image
    Waqas
    Answered on October 03, 2022 at 03:51 PM

    Hi Chris,

    Thanks for getting back to us. When I cloned and tested your form and tried both ways to draw and type, everything worked the way it was supposed to. Take a look at the screenshot below to see my results:

    1664826262_633b3b96bc511_

    1664826343_633b3be770af8_

    For troubleshooting purposes, can you please try to remove the signature field and add it back? If the issue continues, we'll create a performance ticket and forward it to our developer team.

    As soon as we hear back from you, we can move forward with a solution.

  • Profile Image
    Kazor
    Answered on October 03, 2022 at 04:27 PM

    We're still getting a broken image. I already tried to remove the field and add it back, cloning the form but it's still having the same issue.

  • Profile Image
    Lorenz
    Answered on October 03, 2022 at 10:03 PM

    Hello Kazor,

    Thank you for reaching out to Jotform Support. We are sorry that you're having trouble with this. Are you logged in to your account Jotform Account when you check the email notification? I checked your form's table submission and the signature is not broken nor empty, so I don't see any reason for the signature to be broken when received via email notification.

    I do encounter the same behavior, but only if am logged out from my Jotform account, because of how my account's privacy option is configured. Could you please try to uncheck the following privacy option below from your account setting and see if it'll help with the issue?

    1664848900_633b9404d7c2b_612323.png

    Give it a try and let us know how it goes.