What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Mac users reporting that the form just goes blank

    Asked by ICFforms on August 19, 2015 at 11:52 AM

    Hello,

    I have had about 10 clients of ours report that they are using a MAC OS and using Safari and when they are completing any of our forms, they will be in the middle of it and then all of the forms will just go blank.  They have tried other browsers on the MAC but it is still going blank about halfway through.  This is not happening with users who are using another OS.

     

    I did a general search from previous questions to see if this has come up before and I found the attached thread from last month.  Is this still the appropriate way to solve this issue and can it be used with embedded, iframe forms?

     

    Thank you,

    Emily - ICF

    Screenshot
    reporting mac os attached
  • Profile Image
    JotForm Support

    Answered by Boris on August 19, 2015 at 01:58 PM

    I have looked at that other thread, and it is describing a different issue. The issue of that thread was that they were embedding a non-secure (HTTP) form on a secure (HTTPS) website. They were experiencing what is known as mixed-content issues, and that is why changing their form URLs from http to https resolved the issue for them.

    Your issue sounds differently at first glance, but could you please let us know a link to such a form on your website, so that we can check and see if there is anything wrong in the way it is set up?

    We will await your response, so that we can try and troubleshoot this further. I have also cleared your form cache, in case it helps.

  • Profile Image

    Answered by ICFforms on August 20, 2015 at 11:50 AM

    Hello,

    Here is a link to one that I am receiving the feedback on: http://www.coachfederation.org/CCEprogramapp

     

    Thanks,

    Emily - ICF

  • Profile Image
    JotForm Support

    Answered by Welvin on August 20, 2015 at 03:15 PM

    Hi Emily,

    You are currently using our iframe method and I noticed that your iframe codes have a duplicate height and width attributes. One in the inline styles (yellow) and one in the iframe (violet). 

    This is usually made by the CMS. But you could see that the iframe height is way too small compared to the inline styles. In this case, I would suggest changing the 240 to the same value in the inline style which is 12710px. 

    Or, simply re-embed your form again using our iframe method. 

    https://www.jotform.com/help/148-Getting-the-Form-iFrame-Code

    I hope that helps.

    Thanks

  • Profile Image

    Answered by ICFforms on August 20, 2015 at 04:07 PM

    Hello,

    I will do that, but will that fix the issue with our Mac users?  This seems like if it were an issue, other types of users would be having the same issues, but this is just specific to Mac users right now.  Is there a solution for why Mac users are getting a blank screen in the middle of completing the form?

     

    Thank you,

     

  • Profile Image
    JotForm Support

    Answered by Welvin on August 20, 2015 at 05:23 PM

    Since the height is too small, I think the issue is related to that so I would suggest try doing that. You can copy and save the old codes so just in case doing the solution would give you extra problems.

    And I'm sure the others won't be affected by doing that. 

    I have tested your form earlier and I just did it again and still, cannot replicate it in OSX Yosemite Safari Browser emulator:

    Please get back to us if the given solution doesn't do anything.

    Thanks

  • Profile Image

    Answered by ICFforms on August 21, 2015 at 08:43 AM

    Hello,

    I will get with our web manager to see if these can be fixed today and then follow up with the users who were having an issue and see if they are having the same problem.

     

    I will let you know if this doesn't solve the issue!

     

    Thank you!