Configurable list empty but it is marked as required field.

  • Profile Image
    windirect
    Asked on September 01, 2015 at 02:45 AM

    Hello there,

    since some days we have no records in Conigurable list. The setting is "required" !!

    When I test the form is everything okay. I do not understand how users can submit without entry.

    Is this widget changed?

    Thanks for your help

     

  • Profile Image
    ashwin_d
    Answered on September 01, 2015 at 08:13 AM

    Hello windirect,

    I did check your form and found that you have added one condition where if "Tipo richiesta" contains "ho ricevuto il,ho fatto il preventivo" then hide the configurable list widget "Distinta". Please check the screenshot below:

     

    If you check the submissions you have received where you do not see the data for Configurable list widget, they all have "preventivo" in field "Tipo richiesta". This is the reason why the widget was not displayed on form and hence no data is captured.

    Hope this answers your query.

    Do get back to us if you have any questions.

    Thank you!

  • Profile Image
    windirect
    Answered on September 01, 2015 at 09:32 AM

    hi,

    if Tipo richiesta contain : 

    "ho ricevuto il" or "ho fatto il preventivo" 

    the fields should be hidden. That´s okay.  Is the separator the problem ?

     

     

     













  • Profile Image
    windirect
    Answered on September 01, 2015 at 09:47 AM

    if Tipo richiesta contain "Preventivo", Distinta must be visible.  And that works. 

     

    But I get records with Distinta without records!

  • Profile Image
    Charlie
    Answered on September 01, 2015 at 12:53 PM

    Hi,

    There are a couple of things that might be causing this problem.

    It seems like there's a conditional conflict with these parts:

     

    Rather than using "contains", I believe you should use "is equal to" instead.

     

    Also, its possible that there's a code conflict between your website and the form, you can try using the iFrame embed code instead, that should prevent any conflicts. If the iFrame is not possible to use, try following the methods mentioned in this guide: https://www.jotform.com/help/324-A-Guide-To-Forms-For-WordPress-JotForm-Users.

    Please let us know if those changes will give better results.

  • Profile Image
    windirect
    Answered on September 02, 2015 at 07:58 AM

    Hello there,

    The Form works perfectly. The Users say they have entered values. The data will be lost. 

    I use Jot Form  oEmbed Plugin in Wordpress. I've noticed that there's a new version. I have now updatet. I hope that was the problem.

    Thanks for help

  • Profile Image
    Jan
    Answered on September 02, 2015 at 12:21 PM

    I understand that you updated the plugin. Let us know if the issue persist after updating the plugin so that we can further investigate. Thank you.

  • Profile Image
    windirect
    Answered on October 10, 2015 at 06:16 AM

    Hi Guys,

    we have a big problem with configurable list.

    In firefox they will not be displayed.

    Thanks for your help.