What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    How to use calculation widget?

    Asked by isbitt on November 16, 2015 at 10:16 AM
    I would appreciate your help with this one
    When the user selects a reason code “Bill Rate” the below 3 boxes show up. This works on the conditions section which is great
    [cid:image007.jpg@01D1206B.F9213E70]
    However im trying to calculate the net loss/gain based on the formula (New rate – Old rate) * Total Days / Hours
    When I try to create it via the add field section I can’t see to separate these 3 fields and it looks at each one collectively. Could you help?
    [cid:image008.jpg@01D1206B.F9213E70]
    [cid:image009.jpg@01D1206B.F9213E70]
    Thanks
  • Profile Image
    JotForm Support

    Answered by beril on November 16, 2015 at 10:43 AM

    Hi again,

    Unfortunately, the calculation wizard function would only work with the following fields with Numeric entries/options:

    1. Radio Button

    2. Checkbox

    3. TextBox

    4. Dropdown

    5. Text Area

    You can calculate with text box the formula instead of Multiple Text Fields widget.

    If you require any further information, feel free to contact us. We will be happy to assist you.

  • Profile Image

    Answered by isbitt on November 16, 2015 at 12:45 PM
    Thanks for confirming, I have amended the entries using the text box and it now works perfectly
    Thanks
    ----------------------------------------------------------
    Richard Isbitt
    Group Contract Billing & Customer Data Manager
    SThree Plc
    1st Floor, 75 King William Street, London,EC4N 7BE, UK
    ----------------------------------------------------------
    •: +44 (0) 207 264 3573
    • Internal 246 7573
    •:: mailto:r.isbitt@sthree.com
    •: www.sthree.co.uk
    ----------------------------------------------------------
    ...
  • Profile Image
    JotForm Support

    Answered by beril on November 16, 2015 at 02:19 PM

    Hello Richard,

    You're kindly welcome. It is nice to hear that the problem is solved for you.

    If you have any question or issues, please do not hesitate contacting us. We will be glad to assist you.

  • Profile Image

    Answered by isbitt on November 17, 2015 at 06:46 AM
    Hi,
    I am having trouble with the conditions and the browser seems to be removing them from view. They all worked yesterday
    Earlier I had 13 conditions setup but when I previewed the form the options no longer worked
    I deleted 1 of them and now when I review the remaining options im down to 6 conditions and 2 are duplicated
    Is anything going on behind the scenes to cause this?

    ----------------------------------------------------------
    Richard Isbitt
    Group Contract Billing & Customer Data Manager
    SThree Plc
    1st Floor, 75 King William Street, London,EC4N 7BE, UK
    ----------------------------------------------------------
    •: +44 (0) 207 264 3573
    • Internal 246 7573
    •:: mailto:r.isbitt@sthree.com
    •: www.sthree.co.uk
    ----------------------------------------------------------
    ...
  • Profile Image

    Answered by isbitt on November 17, 2015 at 07:45 AM
    Hi there,
    Further to my last email im really struggling with these conditions. Although they were working yesterday im having trouble today. Please could you help
    I have setup a rule to say if the ‘request type’ is XXX, then show a dropdown box (and hide another). However the dropdown box isn’t showing when I make the selection and I am really struggling to understand why. I have removed the ‘hide’ option but this doesn’t solve the issue. Could you please help?
    https://form.jotformeu.com/52513964950359
    [cid:image005.jpg@01D1212D.ABEB3B20]
    These are not showing on the form…
    [cid:image003.png@01D1212C.E0E22650]
    [cid:image004.png@01D1212C.E0E22650]
    ----------------------------------------------------------
    Richard Isbitt
    Group Contract Billing & Customer Data Manager
    SThree Plc
    1st Floor, 75 King William Street, London,EC4N 7BE, UK
    ----------------------------------------------------------
    •: +44 (0) 207 264 3573
    • Internal 246 7573
    •:: mailto:r.isbitt@sthree.com
    •: www.sthree.co.uk
    ----------------------------------------------------------
    ...
  • Profile Image
    JotForm Support

    Answered by beril on November 17, 2015 at 09:14 AM

    Hi Richard,

    I've created a separate thread for you, this question will be answered at the following link below:

    http://www.jotform.com/answers/706264