Updates made to form are not showing in embedded form

  • Profile Image
    lsteinbrink24
    Asked on July 06, 2016 at 02:41 PM

    I want to update names and conditions on my contact us form, but only one section displays the conditions (which is circled on the jpeg submitted with this). My other sections of the form do not display that there are conditions, so before I go and recreate them all, I'm hoping you have a better answer.  I'm not seeing the changes I've made today to the form on my website either, but it could be related to the same issue.  I've sent a test message from my website to see if the form is still working with the conditions I can no longer edit, and they don't appear to be working. My test messages did not get to their chosen recipients. Is there a way you can check on this if it isn't a problem you're aware of already?

  • Profile Image
    david
    Answered on July 06, 2016 at 03:44 PM

    It looks like your form is embedded to your webpage using the full source code. 

    http://www.jotform.com/help/104-How-to-get-the-Full-Source-Code-of-your-Form

    When using this embed method, it takes a snapshot of your forms code.  Since that code is not updated when the form is updated, the updates will not show in the embedded form.

    Removing your current embed code and embedding the form once again should allow for the newest changes to be shown. 

    If you use the regular script embed code:

    http://www.jotform.com/help/67-Which-Form-Embed-Code-Should-I-Use

    Or your forms iFrame code:

    http://www.jotform.com/help/148-Getting-the-Form-iFrame-Code

    Any changes made to your form will be automatically updated in forms embedded to webpages.

  • Profile Image
    lsteinbrink24
    Answered on July 06, 2016 at 04:45 PM
    So any idea what happened with the conditions in place that worked until
    today? Will I have to redo all of them?
    ...
  • Profile Image
    Boris
    Answered on July 06, 2016 at 06:04 PM

    I have checked your Form Revision History, and I see there have been multiple changes on your form's conditions within the last few hours:

    https://www.jotform.com/help/294-How-to-view-form-revision-history

    You may want to try reverting your form to one of its revisions before the conditions were modified / lost, or instead you will need to re-create your conditions for sending the notification email to different recipient based on form selection.

    For setting up the conditions, the following guide should help:

    https://www.jotform.com/help/167-How-to-send-to-a-specific-email-address-based-on-a-selection