What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Image links not working correctly in live form

    Asked by btobias on September 19, 2016 at 01:17 PM

    I created a short form to allow 12 service sites to be browsed by focus or location. I linked each image to the corresponding landing page on our website. The links work perfectly in the jotform preview. But live on our website, if you click on the image you do not reach the landing page. Nothing happens. However, if I right-click on the image and open in a new tab, that works fine. Unfortunately that work-around won't work in the mobile space, and I'd like it to be easier. Please take a look at my links and let me know if something is wrong.

    Page URL:
    http://www.stmarystudentparish.org/asb-site-descriptions/

    image links correctly in JotForm Mobile preview new tab
  • Profile Image
    JotForm Support

    Answered by KadeJM on September 19, 2016 at 03:06 PM

    I see that you're having a problem with linked image fields on your form not redirecting to the appropriate url after being selected and clicked upon.

    Upon further testing of this I found I was able to replicate this issue with a copy of your form I made to check and investigate this issue deeper. I've reassigned your images for the fields and it seems to be working normally on my end now.

    Can you try it again on your end and let us know if it is still a problem or not?

    If needed you can clone my updated version of your form here: https://form.jotform.com/62625364906965 

  • Profile Image

    Answered by btobias on September 19, 2016 at 03:22 PM

    I have the same issue with your form - the links work great until they are live on my wordpress site. However, I tried embedding the form instead of pasting the link, and that seemed to clear up the problem. Perhaps others with this issue should try embedding as well.

    Thank you!

  • Profile Image
    JotForm Support

    Answered by Mike_G on September 19, 2016 at 05:23 PM

    We're glad to know that everything works perfectly for you now. And yes, embedding the form is the best way of adding it to a website.

    Please feel free to contact us anytime if you have any further questions or concerns. Thank you.