Not receiving email notifications

  • Profile Image
    greggusp
    Asked on January 30, 2017 at 04:17 PM

    Hi, 

     

    We're attempting to forward the forms submitted to ticket@uspmotorsports.com

     

    It isn't working. I've changed the settings several times. Still no forward. I clicked the test email button, and that worked. But not when I fill out a form on our site and submit. 

     

  • Profile Image
    AIDAN
    Answered on January 30, 2017 at 05:09 PM

    Hi, thank you for contacting us.

    Upon inspection I found that you are using a custom sender in your form, instead of ours.

    Please check your SMTP configuration for your custom sender, to make sure it follows our guide on setting up SMTP for a form here: https://www.jotform.com/help/244-How-to-Setup-SMTP-for-a-Form

    I would also suggest trying one of our default senders (noreply@jotform.com for example) to see if that sends emails successfully.

    Please get back to us if the problem persists. We will be happy to assist you further. Thank you.

  • Profile Image
    greggusp
    Answered on January 30, 2017 at 05:31 PM

    I got it to work by using a verified email. The new problem is

    I can't the "from" email to be the email address filled out on the form. I am working on setting up this Mandrill account (what a nightmare), and the set by step instructions on https://www.jotform.com/help/240-Set-The-Sender-Email-Address-With-Mandrill-Account seems to be out of date. 

     

    After I managed to create an account through mailchimp, then activate Mandrill, there is no "Get SMTP credentials". When you click on Dashboard, it brings you to a page that says "Set up your sending domain" instead. Which I filled out, and generated an API key, and followed the rest of the steps, but it still does not work. Keeps replying as if it came from support@usp instead of what the customer enters in the email field. 

  • Profile Image
    jonathan
    Answered on January 30, 2017 at 07:40 PM

    Thank you for updating us on the status and letting us know the not receiving email was fixed already.

    Since the new concern was about a different feature, we will resolve it separately on another thread here https://www.jotform.com/answers/1051095

    We will attend to it shortly.