What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Form fields are appearing that shouldn't

    Asked by childrenshealing on March 13, 2014 at 12:58 PM

    I am having issues with the form "Sponsor Registration - Turn on the Light Annual Conference."  When I preview it in JotForm, it looks exactly as it should.  When I view the form on our website, it reveals fields that should be hidden.  I made a clone of the form and tried using that and got the same outcome.

    There are several other JotForm forms on the site that are not having the same issue.  I am not a computer programmer or web designer... I am a psychotherapist who is fairly adept with user-friendly platforms and a quick learner.  I cannot figure out why this is happening - it is previewing just fine, but showing up differently on the site.

    In the event you go to the turnonthelight.org site and the sponsor form appears correctly - don't be fooled. It did that for me once.  I kept going back to the page, refreshing the page, leaving then returning, etc. without ever making any selections on the form.  One time (the 2nd time on the page, I beleive) it appeared correctly.  But multiple times afterwards, it didn't.  The site is currently connected to the Clone version of the form.

    Please help me figure out how to resolve this.  Thank you.

    Page URL:
    http://www.turnonthelight.org/#!sponsor-registration/c1m1b

    Screenshot
    JotForm hidden preview Annual
  • Profile Image

    Answered by pinoytech on March 13, 2014 at 04:23 PM

    Hi,

    It seems like you already manage to fix the issue that you are referring. Its working fine on my end upon checking it.

    Check this video: http://www.screencast.com/t/G75IeOeIkIvr

    Feel free to contact us again if you need further assistance.

  • Profile Image

    Answered by childrenshealing on March 13, 2014 at 05:10 PM
    New response received
    I did nothing to fix it.
    I just went to the page again and it is still happening (screen shot below):
    ...
  • Profile Image
    JotForm Support

    Answered by BDAVID on March 13, 2014 at 09:22 PM

    Hi, upon checking the form it seems to be working as expected on Google Chrome, but I see on FireFox is not, and I have not selected anything, however the hidden fields appear, Have you checked in another browser?

    What could be causing the problem is the script code that is between the head tag:

    I would recommend you to remove all the embedded code of your form and try to embed it again, using the iFrame code, you may take a look a the guide "Adding form to Wix Site". Hope this helps you, let us know what happens.

     

  • Profile Image

    Answered by childrenshealing on March 14, 2014 at 09:30 AM
    New response received
    Thank you. I changed it to iframe and it seems to be working fine.
    ...