What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Submit button not working on Squarespace

    Asked by liquidtown on November 17, 2016 at 03:32 PM

    Hi, I am using the form for customers to choose what alcohol they want to order. It is a massive list of hundreds of drinks split into drop down menus. On the jotform site the form works within minutes of loading. On Squarespace the embedded jotform doesn't do anything. It loads the list after a few minutes and when the Submit button is clicked nothing happens.

     

    If there is further information you need from me just ask. I am also generating a fillable pdf of the form so my client can use it offline.

     

    Thanks

    squarespace submit not working stuck on submit submit button stuck
  • Profile Image
    JotForm Support

    Answered by John_Benson on November 17, 2016 at 05:10 PM

    If I understand you correctly, your Submit button is not working in your Squarespace website but it is working fine in the form's direct link. If yes, please try re-embedding the form using the iFrame method. Here's the guide: https://www.jotform.com/help/148-Getting-the-form-iFrame-code.

    If the issue persists, please provide the website link so that we can investigate it further.

    Hope that helps. Let us know if you need further assistance. Thank you.

  • Profile Image

    Answered by liquidtown on November 17, 2016 at 05:46 PM

    The site is not published yet as my client and I are trying to test the order form on the site before it goes live. I have been waiting for ten minutes and it just sits there with "Please Wait" instead of Submit since I clicked it. I tried the iframe code as you suggested.

    The PDF fillable form has been loading for almost 24 hours and shows no sign of anything except the spinning dots as the loading symbol.
  • Profile Image
    JotForm Support

    Answered by John_Benson on November 17, 2016 at 07:04 PM

    It is possible that there are script conflicts between the form the page where you are trying to embed the form. Please try removing the <script> element below the iFrame code.

    <iframe id="JotFormIFrame-63217386562965" onload="window.parent.scrollTo(0,0)" allowtransparency="true" src="https://form.jotform.com/63217386562965" frameborder="0" style="width:100%; height:539px; border:none;" scrolling="no"> </iframe>
    <script type="text/javascript"> ... </script>

    Unfortunately, we need to check the webpage where the form is embedded so that we can further troubleshoot.

    Please check this guide as well: https://www.jotform.com/help/37-Adding-a-form-to-Squarespace

    I moved the fillable PDF issue on a separate thread. Here's the URL: https://www.jotform.com/answers/992816. We'll attend to that issue shortly.

    Thank you for your understanding.

  • Profile Image

    Answered by liquidtown on November 18, 2016 at 03:48 PM

    Hi, thank you so much for the help and I was able to get a link to the page for you to look at.

     

    https://liquidtown.squarespace.com/barnrestaurant

     

    Thanks,

  • Profile Image
    JotForm Support

    Answered by Jim_R on November 18, 2016 at 06:03 PM

    Thanks for that. See my findings below:

    1. I'm seeing A LOT of console errors unrelated to JotForm when I viewed your website. Most notably are the POST errors pointing to https://liquidtown.squarespace.com/api/census/RecordHit?crumb= URLs.

    These are repeating errors and causes my browser to hang while viewing your website.

    (NOTE: I'm using a system running Skylake with ample amount of RAM, 8GB)

    2. Oddly enough, you said "On the jotform site the form works within minutes of loading" but when I tried viewing your stand alone form, I felt that it takes way too long for it to load compared to the usual.

    3. So I cloned your form hoping to check how it was built but failed to do so. Chrome just becomes unresponsive everytime I try.

    I'll see if I can have one of my colleagues to try cloning your form using his/her own PC. We'll keep you posted on this thread.

  • Profile Image
    JotForm Support

    Answered by Jim_R on November 23, 2016 at 06:31 PM

    My colleague also failed to clone your form. However, it seems that you still have the script tags on your website.

    We implore you to try the suggestions given by my colleague - Here's how your website's source code looks like at the moment. Just remove the script part of the iFrame embed codes like so:

    Related guide: Getting-the-form-iFrame-code