What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Page Break: Next button is triggered when conditional field is filled, instead of once next button is clicked.

    Asked by Diobelle on December 15, 2016 at 11:39 AM

    I am trying to skip to the end of my form (page 13) if someone answers anything but "Yes" on my first question. It isn't working. Can you help? Form is @ https://form.jotform.com/solutio/psr-form.



    This is a re-post of a comment on How to Skip Pages Using Conditional Logic

  • Profile Image
    JotForm Support

    Answered by Kiran on December 15, 2016 at 01:11 PM

    I have checked your JotForm and see that the issue is being caused by the Form Tabs widget. Please try changing the option "Allow navigation without validation" in the Form tabs widget to No so that the condition should be working properly since choosing Yes is conflicting with the condition.

    Thank you! 

  • Profile Image

    Answered by Diobelle on December 15, 2016 at 03:46 PM

    I still can't get it to work.

  • Profile Image
    JotForm Support

    Answered by BJoanna on December 15, 2016 at 06:41 PM

    I have tested your form and I not exactly sure why but next button is activated once fields is filled instead of once next button is clicked. I was also redirected to second page instead to the last page.

    However when I clicked on Next button and Yes was not selected I got redirected to page 13. Are you having same issue?

    I am not sure what is causing this issue. Based on tests I made on my cloned form it is not Form Tabs widget. Same thing is happening even when form tabs widget is deleted from the form.

    I will escalate this issue to our developers and we will inform you via this thread once this issue is resolved.