What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Changes not saving and now half the form is missing

    Asked by cheekyherbs on February 23, 2017 at 01:22 AM

    Would love to know what's going on for the past two weeks.

    I have tried several times to update codes and prices on my order form. It saves the first 20 or so changes, then none after that. According to my log I have made 167 changes today and none of them have registered. They are on the wizard, but even on the preview screen it is not there.

    And now today half the form is missing. But when I look at the log the "current version" says it is all there.

    I'm on firefox, it's embedded on shopify. I've attached a couple of screenshots to give you an idea.

    I'm at a loss at the moment, especially since the bottom 100 or so products are now not even showing on the form - in jotform or on my website. But they do show up on the jotform log. Have switched to v3 and half the form is still missing and no changes have shown up. (I was changing the essential oil prices - now they do not even appear on the form, it cuts off half way through the massage oils.

    Would love some help please.

     

    Screenshot
  • Profile Image

    Answered by cheekyherbs on February 23, 2017 at 01:38 AM

    Here is a screenshot of the log which says an hour ago I made 173 updates. But none have registered. For example, I changed the Aniseed price to 8.09. But not only does this change not appear on the form, Aniseed does not appear because the form does not go past Childbirth Massage Oil.

    Love jotform but having real issues here that I can't fathom. Thanks.

     

     

  • Profile Image
    JotForm Support

    Answered by Nik_C on February 23, 2017 at 05:58 AM

    Hello,

    I'm sorry you went through all the trouble.

    I checked the form but I wasn't able to replicate the problem, the price you changed for Aniseed is 8.09:

    And all items are showing:

    Is the problem happening in your Shopify website where the form is embedded or only directly in form preview?

    I checked your form in Editor as well and it is showing fine there.

    Also, did you try to view the form from a different Browser? It could be a cookie related issue.

    We'll wait for your response.

  • Profile Image

    Answered by cheekyherbs on February 23, 2017 at 10:04 PM

    Hi mate, I couldn't wait for a response so I had to go back to a previous version of the form and start again in jotform version three. That's why it's working. The saves have been instantly talking back to my website, unlike version 4.

    I did clone the broken version - it might not be of use but you can have a play around with it if you like.

    If v3 keeps saving instantly I'll keep using v3 for a while I think, I was having no luck with changes updating in version 4 and I've tried at least four times in the past week. Thanks for touching base.

  • Profile Image
    JotForm Support

    Answered by ashwin_d on February 24, 2017 at 02:56 AM

    Hello cheekyherbs,

    Please note that v3 & v4 both versions have auto save feature and changes made in v4 will also save automatic and instantly. I am not sure what caused this issue in your form. 

    I would suggest you to please edit your cloned form and see if the changes made is not saved successfully. 

    Do get back to us if the issue persists.

    Thank you