Survey Limit to minimum and maximum number is not working using Internet Explorer?

  • Profile Image
    Asked on August 23, 2017 at 09:43 PM

    Hi Sir..

    Im doing the multiple choice selection voting system and in the Multiple choice properties menu -  Survey -  Entry limit to limit the minimum and maximum number of voting is not working.


    In the list, i have 37 of choice to select and i would like to limit the user to vote for Maximum of 3 choice only ..


    I have it setup in the SURVEYing menu, ENTRY Limit - minimum set to 1 and maximum set to 3 , but im still able to choose more than  3 in the survey form .. It is not working, hmm, not sure why.. Could someone help?


    attach the form link



  • Profile Image
    Answered on August 23, 2017 at 11:02 PM

    I cloned your form and I can see that the Entry Limits is set to a maximum of 20. Please change it to 3 to fix the issue.

    Here's a screenshot of Entry Limit set to 20:

    Here's a screenshot of Entry Limit set to 3:

    If you want to test it, please check this clone form:

    Please try it again and if the issue persists, please let us know.

  • Profile Image
    Answered on August 23, 2017 at 11:23 PM

    Hi Sir,

    Thank you for the fast response! Appreciate it !

    I did that , and it does not work in Internet Explorer.. but the entry limit only work on firefox browser..

    attach the picture at Internet explorer.. you can see , i click more than 3 item.. The limit max icon does not pop up

    .. Is that a way to fix it ? My colleague is using the internet explorer, she is facing the same problem too ..

  • Profile Image
    Answered on August 23, 2017 at 11:54 PM

    I opened your form ( using Internet Explorer version 11 and it is working properly on my end. 

    Here's the form test using Internet Explorer 11:

    - To test it, try selecting 4 option and then click on a random area of the form.

    May I know what is the Internet Explorer version you're using? If possible, please update it to the latest version. 

    Let us know how it goes. Thank you.

  • Profile Image
    Answered on August 24, 2017 at 09:05 PM

    Hi John,

    Appreciate your fast response!

    im using internet explorer 11 .. it is the latest version .. When i use internet explorer to open , it is having the some problem, it does not able to do loading.. im not sure why..


    Anyway, i had tested the form at Internet Explorer 11 , it is having the same problem as mention ..


    does not really know why hmm.. even my colleague laptop is having the same problem, i think it only work on Google chrome or Firefox ..

    Attach the internet explorer at myform and .. you can see the font is not as 3D as firefox here.

    hmm, im really puzzle, most of my colleague Laptop is having this problem, not able to vote less than 3 person ...

    First Picture - Internet Explorer - Myform voting site

    Second Picture - Internet Explorer -

    Third Picture - Firefox - myform voting site


  • Profile Image
    Answered on August 24, 2017 at 10:21 PM

    Thank you very much for the screenshot and the complete detail of the issue. 

    Upon checking the screenshot that you have provided, I can see that you're using the different form when you tested it to Firefox and Internet Explorer.

    Image 01: (Internet Explorer using Form ID: 72341446357457)

    Image 02: (Mozilla FireFox using Form ID: 72348920260959)

    Could you please try it again using Mozilla FireFox and Internet Explorer? But, use this link only to test it:

    Let us know how it goes. 

  • Profile Image
    Answered on August 24, 2017 at 10:28 PM

    Hi John,

    Thanks for the fast reply!

    attach 2 picture using the new link


    Picture 1: Firefox

    Picture 2 : Internet Explorer (Updated to KB4034733 as per your internet explorer version)


    Firefox worked well but not IE ... hmmm.. Still the same problem....


  • Profile Image
    Answered on August 24, 2017 at 11:01 PM

    I was now able to replicate the issue when I disable the Active Scripting in the Internet Explorer settings. To enable it, please follow this guide:

    I also created a screen animation video to test it:

    If you're using Local Intranet Zone, please enable the Active Scripting on that page too:

    I hope this helps. If the issue persists, let us know. Thank you.

  • Profile Image
    Answered on August 24, 2017 at 11:55 PM

    Hi John,

    I did that, but it is not working, did a restart laptop  after enable and disable and enable it.. attach the script enable and disable, i had it disable and enable but it is still not working

  • Profile Image
    Answered on August 25, 2017 at 03:31 AM

    We are sorry for this confusion.

    I checked this form on the IE11 and not find a problem as my colleague mentioned. The form is not submittable if the user selects more than 3 options. 

    However, if you click to checkboxes and not click anywhere else on the form, you are able to select as much option as you choose. The error shows up once you click to somewhere else outside the checkboxes. On the other hand, you won't be able to submit form even if you select all the options. Here is the demonstration of what I told here:

    Could you please confirm if you are able to submit form with more than 3 selections? If so, please check browser console and send us the screenshot of the error. To open your browser console; write click and select Inspect Element.

    Then, click to Console tab from the opening window.

    I hope, everything is clear here for you and that's help. If you have more questions, please feel free to contact us. We would be pleased to assist you for any issue you may have. 

  • Profile Image
    Answered on August 26, 2017 at 12:58 AM

    It is not a confusion.. hmm... It is working now, im not sure why is that..

    Earlier on when i select more than 5 choices , it does not pop up the maximum limit and im able to submit it with 5 choices although the survey max limit is 3 only.. Im using my home internet .. the link does not work using my office internet, i can back on Monday and try it again.. i will send a screen shot to you using my office internet.. hmm..

    attach the screen shot while using my home broadband .. It is working well using IE!

  • Profile Image
    Answered on August 26, 2017 at 02:31 AM


    Upon checking the screenshot of your last post, you enable the active scripting of the Local Intranet Zone. Here's your screenshot:

    Please try it again but this time select the Internet Zone and follow this guide:

    If the issue still persists, please contact your IT department.

    Let us know how it goes. Thank you for your cooperation.