I am being prompted that I need to upgrade