Hidden fields appear even if the auto hide option is already enabled.

  • Profile Image
    Benicabopm
    Asked on February 06, 2018 at 05:11 PM

    when I view my form thru submissions the empty hidden fields still display even though I have asked not to display empty (hidden) fields. Strangely only the date of birth field and telephone number field show, the name field, the passport field and address field remain hidden (when empty). 

  • Profile Image
    Jed_C
    Answered on February 06, 2018 at 08:08 PM

    I'm unable to reproduce this issue. Enabling the "auto hide empty fields" hides the empty fields from my end.

    Can you please confirm that the option shown in my screencast below is already checked on your end?

    1517965705hide_fields.gif

    Looking forward for your response.

  • Profile Image
    Benicabopm
    Answered on February 07, 2018 at 10:51 AM

    Please find screen shot of my problem, as you can see the auto hide is checked yet just the date of birth and phone number fields keep displaying even though empty . Thanks for your assistance.1518018496Jotform.jpg

  • Profile Image
    david
    Answered on February 07, 2018 at 12:00 PM

    This might be due to using the encrypted submission data feature.  Since the data is encrypted, the system interprets all fields as being filled.  With the encrypted submission data feature removed, auto hide empty fields is functional.

  • Profile Image
    Benicabopm
    Answered on February 07, 2018 at 03:38 PM

    Hi David , thank you for your reply. I understand the logic behind this as it does make sense but ... (always a but) if that was the case then why doesn't the other 4 fields show e.g full name field, address field, passport field and relationship to head guest ? if the system interprets all fields as filled then surely they should all show while I have my form encrypted. Thank you for your help and sorry for the headache . 

  • Profile Image
    Jed_C
    Answered on February 07, 2018 at 04:00 PM

    I'm unable to replicate this on my encrypted form. Those fields you mentioned hides on my end if I select the auto-hide empty fields checkbox.

    Can you please confirm if by making another submission you are still able to reproduce this? I'm wondering if this issue happens only with your past submissions.

    Looking forward for your response. 

  • Profile Image
    Benicabopm
    Answered on February 07, 2018 at 04:22 PM

    Hi Jed_C , thank you for getting back to me. I have done another test for to check if this still happens and it does, please take a look at the screen shot.1518038521jotform_test2.jpg

  • Profile Image
    Benicabopm
    Answered on February 07, 2018 at 04:32 PM

    I have resent the form as it appeared you couldn't see the date of submission1518038734jotform_test2.jpg


  • Profile Image
    Jed_C
    Answered on February 07, 2018 at 06:38 PM

    I'm able to reproduce it if I cloned your form but I cannot reproduce if I create a new form and use those fields you've mentioned that weren't hiding. 

    Can you please try creating a new form with fields that were reported not hiding even if it's set as hidden then try to submit a blank form and see let me know if this issue still persist on your end? Could be isolated to this form http://www.jotformeu.com/form/80263872019356 only. 

  • Profile Image
    PioneerProperty
    Answered on February 07, 2018 at 09:06 PM

     

    Hi there,

    How do I get the Geocomplete Widget address dropdown to go OVER the other form fields as opposed to what it currently does... pushes them down? When you begin typing in an address, it displays a dropdown of 5 addresses which pushes all other form fields below it, down. Is this a bug?


    1518055605Form_Dropdown.jpg

  • Profile Image
    EltonCris
    Answered on February 08, 2018 at 01:00 AM

    @PioneerProperty

    We will answer your question in a separate thread here https://www.jotform.com/answers/1377225