My payment processing service, Authorize.net, is requiring that I upgrade to TLS 1.2. Is that something you handle for me?

  • Profile Image
    paulnugent
    Asked on February 26, 2018 at 12:33 PM

    Hello. My payment processing service, Authorize.net, is requiring that I upgrade to TLS 1.2. Is that something you handle for me? I use a form that you have integrated with Authorize.net. Also, do you offer an image of a TLS certificate that I can place near my form?

    Paul

  • Profile Image
    John_Benson
    Answered on February 26, 2018 at 02:06 PM

    Yes, our forms are using TLS 1.2 encryption on its certificates. We are fully PCI compliant and our payment integrations are up to date. You have nothing to worry about this and do not need to perform any actions regarding this matter.

    151684687901-25-18s2m.png

    I also believe Authorize.Net already informed their users about these changes last year. You can check the reply of our developer on this thread.


    You might want to check this page as well: https://www.jotform.com/security/.