I am having issues with some conditions that I've set

  • Profile Image
    Laurajordanwms
    Asked on March 21, 2018 at 09:38 AM

    I have set up a couple conditions that doesn't seem to be translating correctly to the form. 

    Firstly, I would like an upload option to appear only when one item is selected in an earlier question ("Gift Type (check all that apply)" and the selection is "Westminster Fund Multi Year Pledge"). The upload option "Upload signed Westminster Fund Multi Year Pledge Agreement" should then appear. Currently when I preview the form, without selecting anything, that upload option appears. That is the first issue with this condition (Condition #15).

    Secondly, and related to this condition, is another condition related to the same "Gift Type" question (Condition #14), that if any of the other options are selected, then the "Upload signed Westminster Fund Multi Year Pledge Agreement" should hide and "Upload signed Campaign Commitment Agreement" should show. Currently, both upload options are showing.

    I realize this is a pretty complicated question, so if any other details or information would be helpful to share, feel free to ask. Thanks in advance!

    Update: In playing around with this issue, I realized that the order in which I click the selected items under "Gift Type" seems to play a role in what upload options appear. For example, if I click "Endowment" first and then "Westminster Fund Pledge", the "Upload sign Campaign Commitment Agreement" appears, and the "Upload signed Westminster Fund Agreement" does not - this is correct, BUT if I were to select "Westminster Fund Pledge" first, then both upload options appear, and that is incorrect. I would prefer it work correctly in both scenarios...

  • Profile Image
    BJoanna
    Answered on March 21, 2018 at 12:29 PM

    I inspected your form when the file upload field is not shown when the form is loaded. I saw that you set the condition to hide it if the "Gift Type" field is empty.

    It also seems that you changed or added some other conditions because conditions #14 and 15 are not related to the file upload fields. 

    It seems that there is a conflict between your conditions. You set multiple conditions to show or hide your file upload fields. I would suggest you to double check all your conditions. 

    If you are unable to fix your conditions, please tell us when should exactly each of the file upload fields be shown. Should the users be able to select multiple options?