PDF Embedder Widget not working??

  • Profile Image
    jmaples
    Asked on August 28, 2018 at 11:37 AM

    How long does it take for a .pdf file to upload and be viewable using the PDF Embedder Widget?

    I've uploaded a 4 page .pdf document and it's not showing up. Should I wait and come back to it later? Will it eventually show up?

    I've uploaded the .pdf, and I've clicked the "Update Widget" button you see in the attached screenshot. Everything looks good, except it doesn't show up. 

    Even when I publish the form, it's not showing up.

    I'm using Google Chrome browswer, and Windows 7 professional, with Service Pack 1. I have a 32-bit Operating System.

  • Profile Image
    jmaples
    Answered on August 28, 2018 at 11:50 AM

    New wrinkle to this issue. I have attempted to upload different .pdf files, other than the one I want to upload. The embedder appears to allow some .pdf's, but not the one I want to use. Absolutely crazy! I've put two .pdf embedder widgets on the same page of the form for you to see this problem.

  • Profile Image
    Kevin_G
    Answered on August 28, 2018 at 01:23 PM

    What is the difference between the files you have uploaded? 

    I would recommend you to try renaming the field that is not showing, try removing the spaces from its name and see if that work, if the problem persists, please kindly share us the file to support@jotform.com including this thread id in the subject 1565071, let us know on this thread once you have sent the email so we can check it. 

  • Profile Image
    jmaples
    Answered on August 28, 2018 at 01:43 PM

    Thread I.D. 1565071

    I've tried to rename it before. I took the dashes out of the date I had in the name. The other .pdf which does show up has spaces in the file name and it doesn't matter. Before I contacted you the first time, I noticed that the file size was much smaller for the one I was wanting to embed. it was less than 1MB. The files that would show up were bigger, like 5 or 6MB. So, I tried saving it to a bigger file size, and I was able to do that. I saved it to 9MB. It still wouldn't show up. It's very, very strange how the one I'm wanting to upload will not show.

  • Profile Image
    DonaldHag
    Answered on August 28, 2018 at 03:18 PM

    To look into this further, we need access to the PDF you are trying to upload. Please upload the PDF to Google Drive or Dropbox and share the link with us here. Please make sure the right permissions are set so we can download the PDF and check it out.


  • Profile Image
    Victoria_K
    Answered on August 28, 2018 at 05:39 PM

    Thank you for additional information. Personally I can not see any reason why the name of this file was causing the issue. But, after I have removed spaces, the file was uploaded and shown properly on your form: https://form.jotform.com/jmaples/new-hire-packet 

    Can you please check if it is displayed on your device now?