Progress Bar widget not counting the required fields for a specific field

  • Profile Image
    New_Lab_Prototyping
    Asked on April 11, 2019 at 12:11 PM

    Hi there!

    I'm working on this form:

    https://form.jotform.com/90998386591175

    The progress bar widget at the top works great for the most part, except for some reason it's not registering one of the conditions I have set to require fields based on the answer to certain questions.

    If you skip past the first page by selecting "none of the above", you'll get to a page with a few single-choice questions on it. For each of those questions the "want to" and the "don't want to" answers will show and require an additional question on the following page, and when I select one of those answers on most of the questions the "X / Y Required Fields Completed" thing increments Y (the tally of total required fields).

    For some reason, this isn't happening on the "Free Consultations" question. The question on the following page is showing up, and it's marking as required (and the form is requiring me to fill the question out), but it doesn't increment Y.

    This is an experience issue more than a hard use issue - the questions are working as they should, the progress bar widget just isn't registering it. Let me know if you have any solutions for me, thanks!

  • Profile Image
    Kiran
    Answered on April 11, 2019 at 01:54 PM

    I have checked your JotForm and was able to replicate the issue at my end with your form. However, as I tried cloning your JotForm to my account it worked fine. I have tried clearing the form caches of your account and it seems to be resolved the issue.

    Please check and let us know if you need any further assistance. We will be happy to assist. 

  • Profile Image
    New_Lab_Prototyping
    Answered on April 15, 2019 at 10:44 AM

    Works great, thanks!