Occasionally after filling out form, once the user hits submit, it says "please wait" and never goes through

  • Profile Image
    TheMurrayInsuranceAgency
    Asked on July 12, 2019 at 11:41 AM
    Second, occasionally after filling out form, once the user hits submit, it says "please wait" and never goes through. The form submission is never logged.
  • Profile Image
    BJoanna
    Answered on July 12, 2019 at 11:54 AM

    I was not able to replicate this issue when I tested the form. I was redirected to the Thank You page and the submission went through. 

    Is your form embedded? If the issue is related to the embedded form, please provide us a webpage URL and we will test the form there. 

    If the form is not embedded, do you know how often is this happening? Do you know if the issue is related to some specific device or browser?

  • Profile Image
    TheMurrayInsuranceAgency
    Answered on July 12, 2019 at 12:16 PM

    The "please wait" message is still appearing, but only on one computer.
    When I fill out the form from my computer, it goes through without a problem.
    When we use my boss' computer, it will not submit. Any ideas on what we should check for that?

    Also, it is not embedded.

  • Profile Image
    IvayloK
    Answered on July 12, 2019 at 12:28 PM

    Can you please try to clear cache, cookies and recent history in your browser and use different browser, if still not working?

    Please test and let us know. We will wait for your response.