Conditional email is not sending.

  • Profile Image
    Jennifer_Sanford
    Asked on February 12, 2021 at 09:36 PM

    I set conditions for certain emails to be sent out based on the responses in the questionnaire. However, I'm not receiving any of the emails. How can I fix this?

    1. I tried to refresh
    2. I went over all of my conditions to make sure they make sense
    3. I tried using different email addresses
    4. I tried changing my name and that still doesn't work

    Neither the approval nor denial emails are working. The only thing I am getting is the notification on my end.

  • Profile Image
    Jed_C
    Answered on February 13, 2021 at 04:23 AM

    Please replace the {email} with {yourEmail}. That should trigger the email condition.

    1613208203_60279a8bc6d06_The Easiest Onl

    Let us know how it goes.

  • Profile Image
    Jennifer_Sanford
    Answered on February 16, 2021 at 11:11 PM
    That didn’t work. I want the results from the questionnaire and the email
    to go to the person who filled out the form. Not me. How can I fix this?
    ...
  • Profile Image
    Jed_C
    Answered on February 17, 2021 at 12:41 AM

    I checked your form and I see that you have set it to send to support@bolderfinancials.com email. If you want it to send to the person who is filling the form, you should put {yourEmail} like what I've previously suggested.

    1613540194_602cab62177b3_The Easiest Onl

    Another suggestion is to change the "Sender Email" to noreply@jotform.com instead.

    1613540272_602cabb0f2817_norep.png

    Another suggestion is to change the "ANY" to "ALL" to avoid triggered both the deny and approved email since what you are using currently is the "ANY" rule, this means that is any of the conditions for approve and deny field is selected, both emails will be triggered. Setting it "ALL" will only trigger it if the condition is ALL true.

    1613540483_602cac8329edd_ALL.png

    Let us know how it goes.

  • Profile Image
    Jennifer_Sanford
    Answered on February 17, 2021 at 08:55 AM
    It’s working now. Thank you!!
    ...
  • Profile Image
    Jennifer_Sanford
    Answered on February 17, 2021 at 09:22 AM
    Last question, how do I can delete the empty option from the drop down
    menu? I don’t know how I got those empty spaces.

    ...
  • Profile Image
    Richie_P
    Answered on February 17, 2021 at 09:40 AM

    I have moved your question to a new support ticket.

    Kindly follow this link https://www.jotform.com/answers/2904521

    Thank you.