Two JotForms were submitted but only one got triggered in Power Automate

  • Profile Image
    shaadmin
    Asked on October 28, 2021 at 04:36 AM

    Hi Team,

    I am having serious problem in triggering the Power automate based on the Jotform submission. I have entered two forms simultaneously but only one got triggered but the other one not triggered at all..


    Can you please help me to resolve this issue ? Looking forwared to your response

    FYI, this is the submission Id (5112070740524471257)

  • Profile Image
    Tommaso_F
    Answered on October 28, 2021 at 06:01 AM

    May I ask you to once disconnect the integration, and then reconnect it again?

    Around when did you notice that the issue started?

    Please try checking with the flow checker tool and see if there are any errors. Here's a link with details about how to use it: https://docs.microsoft.com/en-us/business-applications-release-notes/october18/microsoft-flow/flow-checker

    After that, please check the connections option and see if the account is connected properly. Here's a screenshot sample:

    1625779778_60e76e427e5dd_

  • Profile Image
    shaadmin
    Answered on November 01, 2021 at 06:53 AM

    Hi Tommaso_F,


    Yes, I have verfied the connections and steps you have given. But this issue seems to be randomly coming while re-submitting the form through edit URL.

    Like there is a glitch (error popup) when submitting the form but the new changes have been saved. But flow is not triggering at all and also "Thank you page" was not showing at all. When I tried to reproduce this its not happening again. !!!!!

    Please guide us !!

    Thanks

  • Profile Image
    Yau_C
    Answered on November 01, 2021 at 07:21 AM

    Hi,

    There are three forms in your account.

    Please specify which form by providing the form-url.

    If your issue is 'Thank you page was not showing at all', we may need to send testing data directly from your form in order to test it.

    But we need your explicit permission before we can send directly from your form.

    Please reply with your permission if you want us to proceed.

    Thank you.


  • Profile Image
    shaadmin
    Answered on November 03, 2021 at 04:48 AM

    Hi ,

    This is the form URL that we are using..

    https://www.jotform.com/build/211524423438450

    Please let me know if there is anything required

    Thanks
    CME

  • Profile Image
    Tommaso_F
    Answered on November 03, 2021 at 06:06 AM

    > (error popup) when submitting the form but the new changes have been saved. 
    Could you please show us a screenshot of this error popup?

    Regards.