Not receiving all responses

  • Profile Image
    rachelishiguroyoga
    Asked on October 31, 2021 at 07:34 PM

    I've been using Jotform for registration forms since February with no known issues. In the past two weeks, I've had two individuals tell me they filled out the forms, clicked the submit button, and received confirmation it went through. However, I didn't receive their responses in my inbox. It's possible this is user error; however, as it's come up twice in the very recent past and clients were very clear they submitted the form, I'm wondering if there's an issue. Any suggestions?

  • Profile Image
    roneet
    Answered on October 31, 2021 at 09:10 PM

    Thanks for reaching out to us!

    May we know if you could see the submission in the Tables but no notification received?

    Please send the Submission IDs so we can check them.

    Have you received it now twice?

    Thanks.

  • Profile Image
    rachelishiguroyoga
    Answered on October 31, 2021 at 10:33 PM

    Thank you. I didn't receive any notification, nor was I able to see any record of the submission in the tables. The data just vanished. The client told me they saw a confirmation that their submission went through, but they don't have any record of it.

    Yes, this occurred twice in October with two different clients. Unfortunately I don't have any ID for the submissions.

  • Profile Image
    Yau_C
    Answered on November 01, 2021 at 01:23 AM

    Hi,

    Please provide the time and date on which it was sent as well as the recipient of this Notification email.

    We will then be able to trace it for you. Thank you.