Why my form does not appear exactly the same in the web browser?

  • Profile Image
    clyde_lamble
    Asked on May 28, 2014 at 06:21 PM

    I have check the form on your platform and it works great. When i copy and paste the source code it wont seem to display a drop down list correctly in iWeb. And when I publish the site to the internet it displays the drop down list correctly but not the bottom of the form (ie the submit bottom. i have tried various options, but can not seem to locate the issue if you can advise?

     

    Great platform otherwise! and thanks for the help!

  • Profile Image
    jonathan
    Answered on May 28, 2014 at 08:35 PM

    Hi,

    Please review also this JotForm user guide on -Adding-Form-to-iWeb 

    If the JotForm guide will not work on you end (there were rare cases like this), you can also then follow the more comprehensive guide from a user/contributor here

    http://www.allaboutiweb.com/2009/02/add-a-form-to-iweb/

     

    Hope this help. Please inform us if you need further assistance.

     

    Thanks!

  • Profile Image
    clyde_lamble
    Answered on May 28, 2014 at 09:01 PM
    Hi,
    I have done this numerous times and managed to copy the form without hassle to iweb and publish subsequently.
    However the form does not appear the same as in "the preview" function on jotform (as i want it to appear) but rather is is cut off at the bottom and hence a user to the website can not submit the form - as this bottom at the bottom remains is cut off!?
    ...
  • Profile Image
    EltonCris
    Answered on May 29, 2014 at 01:41 AM

    @clyde_lamble 

    That's a common issue when embedding script on iWeb. The most efficient way to resolve that is to increase the height of HTML Snippet on your iWeb program where you have pasted your form code. This should resolve cut off issues on your page.

    Your current HTML Snippet produces 931px height which is not enough for the form to appear completely on the page. The form requires at least 1200px.

    Thanks!