Google Analytics is not up to date

  • Profile Image
    MartinGWilliams
    Asked on June 29, 2014 at 05:19 AM

    Hi

    A massive chunk of my Google Analytics goals are being shows at submit.jotform.co or submit.jotformpro.com. I've tried the various workaround suggested on the forums, adding to tracking codes and changing thank you URLs etc, but I can't get anything working.

    Can anybody suggest a workaround for this please? It's killing me!

    M

  • Profile Image
    ashwin_d
    Answered on June 29, 2014 at 05:47 AM

    Hello MartinGWilliams,

    I am not sure if I have understood your question correctly.

    Have you already tried our "Google Analytics" widget? Please take a look and this should be straight forward implementation. You need to just add the widget in your form.

    Hope this helps.

    Do get back to us if you have any questions.

    Thank you!

  • Profile Image
    MartinGWilliams
    Answered on June 29, 2014 at 06:43 AM

    Hi

     

    Yes, I had installed the widget a few weeks ago, and it's still the same problem?

    http://tinypic.com/r/5dw4l1/8

  • Profile Image
    jonathan
    Answered on June 29, 2014 at 09:41 AM

    Hi,

    When using the Google Anaylytics Widget, please make sure that the Google analytics account ID is correct.

    Most of the time, due to wrong Google Analytics account ID, the wdiget will not work. So, please double check that this is correct, and then try testing again your form.

    At the most, you can also try removing that widget and then add it back. See if it makes any difference.

    Please continue updating us if issue remains.

    Thanks!

  • Profile Image
    MartinGWilliams
    Answered on June 29, 2014 at 10:34 AM

    The problem is your analytics widget is out of date. This thread, I hope will fix it.

    http://www.jotform.com/answers/361363-How-to-track-a-form-all-the-way-through-Google-Analytics

     

  • Profile Image
    jonathan
    Answered on June 29, 2014 at 04:03 PM

    Hi,

    Thank you for pointing it out.

    You are correct, it must be due to it not being up to date, as I can see there was already a ticket report requesting for update. Its just that our developer have not reached the ticket yet. We need to wait until they have update for it.

    For the meantime, you may also want to try applying the solution offered by our colleague Mike_T on that thread. Which, as you can read have fixed the problem already to the user who reported it.

    Quoting Mike_T's solution here:

    ""Do you use a new Google Universal Analytics? In such case it might be possible to resolve the issue by adding our domain into your Referral exclusions.

    Note, that the form submit domain name might be a bit different, here are some examples:

    submit.jotform.com
    submit.jotformpro.com
    submit.jotform.us
    submit.jotform.co

    Can you please check the referrer under your Google account and add it to the Referral exclusions to see if that work as expected?""

     

    Please try also. Inform us if you continue to have issue with this.

    Thank you.