Configurable List widget data is not displayed when the browser back button is clicked after form is submitted.

  • Profile Image
    swapna_summit
    Asked on July 08, 2014 at 02:39 AM

    My form shows that the configurable list widget  Add Button is not showing after a day when i open my form in online?

  • Profile Image
    ashwin_d
    Answered on July 08, 2014 at 09:04 AM

    Hello swapna_summit,

    I'm sorry for the trouble caused to you.

    I did check your form and I am unable to replicate the issue you are having. The "Add a Learner" button is showing up in your form as expected.

    Please check the screenshot below:

    We had some issues with the "Configuration List" widget where the add button was not visible when the maximal/minimal row numbers were set to "0". This issue is already resolved.

    I would suggest you to please check it again and get back to us if the issue persists. 

    Thank you!

  • Profile Image
    swapna_summit
    Answered on July 08, 2014 at 09:12 AM

    Hi thanks i got another issue with configurable list widget what ever data i put it into the list is not viewed back when i am going back via browser's back button.

     

    my url is   http://form.myjotform.com/form/41773621486561

     

  • Profile Image
    ashwin_d
    Answered on July 08, 2014 at 10:28 AM

    Hello swapna_summit,

    You mean to say that when you input data in your form's "Configurable List" widget and you submit the form successfully. When you click on the browser back button from your thank you page the data of "Configurable List" widget is not visible?

    I am not sure if this was working before. I am reporting this to our back end team. We will get back to you as soon as we have any update from them.

    Thank you!

  • Profile Image
    MacLuc
    Answered on July 09, 2014 at 03:45 AM

    What is saved in browser's memory and restored after clicking "back" button, depends on browser and user's settings - usually browser restores data in form fields, but not the changes in page content (like table rows added by Configurable List). Sorry, but it's not a bug and it won't be fixed - forcing browser to restore Configurable List contents would be tricky and our forms were never supposed to handle "back" button this way - if user submits form, we rather don't expect him or her to go back and submit it again with the same data.