What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    submissions page not displaying all the submissions - I'm missing two responses

    Asked by dickeyad on September 11, 2014 at 09:27 PM

    The url:

    http://www.jotform.com/submissions/42538389349974

    Only displays three responses.

    However, there are four responses when viewed in: 

    http://www.jotform.com/myforms

    1. mcc
    1|2
    2. scrb
    1
    lt
    1234
    st
    1234

    Request: PUT /form/42538389349974/submissions

    Request Payload: [{"1":"1|2","2":"1","3":"1234","4":"1234"}]

    Screenshot
    Submissions all submissions all JotForm style font
  • Profile Image
    JotForm Support

    Answered by TitusN on September 12, 2014 at 12:32 AM

    Hello, 

    Just to clarify - this form had four responses, and now it has two? 

    I checked your account history - and could not find any deletions that might have caused this. 

    There is no indication that the form on your screenshot received more than two submissions up until now.

    Could it be a different form you are referring to? The form in the screenshot shows 2 Submissions, and not three.  

    Please also help us understand how you use your form -  It does not have a submit button for accepting form responses. 

    I've also forwarded this to our developers so that they can check and possibly advice further.  

    Looking forward to your response. 

     

  • Profile Image

    Answered by dickeyad on September 12, 2014 at 04:26 PM

    The form has four responses, but when viewing http://www.jotform.com/submissions/42538389349974 only three are displayed.

    Note that the issue is responses, not submissions. Yes, there are two submissions, and each submission consists of four responses. (By response, I mean "answer to an individual question", not "a single submission". Sorry if this causes confusion; hope this clarifies). 

    I also tried to retrieve the submissions via curl, but got a 401 "You're not authorized to use (\/submission\/42538389349974)".

  • Profile Image
    JotForm Support

    Answered by steve on September 12, 2014 at 05:41 PM

    Hello-

    I checked this form in multiple places: https://www.jotform.com/42538389349974

    It appears to have three submissions:

    Only 3 submissions in our admin panel:




    Only 3 in regular submission view:


    Only 3 in API view, http://api.jotform.com/docs/#form-id-submissions:


    If there were 4 submissions at one point it looks like the fourth was deleted. I also checked the email records, but looks like notifications weren't set up to send these.

    Unless there's something we're missing, it looks like the fourth submission is gone. If you edited the form in between submissions, you might have lost data. Such as if you deleted fields. There's a warning that pops up before any information is removed though. Let us know if this helps explain your situation. I'm not going to escalate this to development unless it looks like there's an error with our system or any indication of missing submissions.

    Regards

  • Profile Image

    Answered by dickeyad on September 12, 2014 at 06:50 PM

    I still believe there is an error. I posted four responses, yet your records indicate only three. 

    This is what was sent to the server:

    Request: PUT /form/42538389349974/submissions

    Request Payload: [{"1":"1|2", "2":"1", "3":"1234", "4":"1234"}]

    The form was not edited between submissions.

    Is there a way that I can verify the responses via curl? Then I can test everything via curl to make sure that the responses are being recorded correctly.

    As you see above, when I tried to GET /submission/{id}, I got a 401 error. Here is the command that I used (apiKey removed):

     

    curl -X GET "https://api.jotform.com/submission/42538389349974?apiKey="

    Why am I getting a 401 error when I do this?

  • Profile Image

    Answered by dickeyad on September 12, 2014 at 06:55 PM

    Ok, I see that I was using the wrong API method.

    Now that I am using the correct method (GET /form/{id}/submissions), I am getting four responses:

    formId = 42538389349974

    Response:

    { "responseCode": 200, "resultSet": { "offset": 0, "limit": 100, "orderby": "id", "count": 3 }, "message": "success", "content": [ { "id": "286361061681676526", "form_id": "42538389349974", "ip": "68.174.117.186", "created_at": "2014-09-12 15:57:41", "status": "ACTIVE", "new": "0", "flag": "0", "updated_at": "2014-09-12 16:22:18", "answers": { "1": { "text": "1. mcc", "type": "control_checkbox", "answer": "1", "prettyFormat": "1" }, "2": { "text": "2. scrb", "type": "control_radio", "answer": "1" }, "3": { "text": "lt", "type": "control_textarea", "answer": "Bobbin I." }, "4": { "text": "st", "type": "control_textbox", "answer": "High job i." } } }, { "id": "286293629912463483", "form_id": "42538389349974", "ip": "64.121.114.219", "created_at": "2014-09-11 21:13:49", "status": "ACTIVE", "new": "0", "flag": "0", "updated_at": "2014-09-11 21:15:09", "answers": { "1": { "text": "1. mcc", "type": "control_checkbox", "answer": "1|2", "prettyFormat": "1|2" }, "2": { "text": "2. scrb", "type": "control_radio", "answer": "1" }, "3": { "text": "lt", "type": "control_textarea", "answer": "1234" }, "4": { "text": "st", "type": "control_textbox", "answer": "1234" } } }, { "id": "286291871681239337", "form_id": "42538389349974", "ip": "68.174.117.186", "created_at": "2014-09-11 20:44:30", "status": "ACTIVE", "new": "0", "flag": "0", "updated_at": "2014-09-11 20:45:33", "answers": { "1": { "text": "1. mcc", "type": "control_checkbox", "answer": "1", "prettyFormat": "1" }, "2": { "text": "2. scrb", "type": "control_radio", "answer": "1" }, "3": { "text": "lt", "type": "control_textarea", "answer": "Ugh" }, "4": { "text": "st", "type": "control_textbox", "answer": "Ugh" } } } ], "limit-left": 9990 }

    Notice that there are FOUR values in the answers object, which is what I expect, but which is NOT being displayed here: http://www.jotform.com/submissions/42538389349974 . When I go to that page, I only am seeing THREE answers.

    Sorry that's a mess. Here's a closeup of what I am referring to:

    "answers": {
    "1": { "text": "1. mcc", "type": "control_checkbox", "answer": "1|2", "prettyFormat": "1|2" },
    "2": { "text": "2. scrb", "type": "control_radio", "answer": "1" },
    "3": { "text": "lt", "type": "control_textarea", "answer": "1234" },
    "4": { "text": "st", "type": "control_textbox", "answer": "1234" } } }

  • Profile Image

    Answered by dickeyad on September 12, 2014 at 06:59 PM

    Steve, to clarify the "count" field that you pointed out is the number of SUBMISSIONS, not the number of ANSWERS. Each submission has 4 answers. 

  • Profile Image
    JotForm Support

    Answered by steve on September 12, 2014 at 07:28 PM

    Hello-

    I looked into this a bit more. It looks like some of your submissions are corrupted. Maybe it's because you were using a PUT statement when you intended to use a GET. I was able to view all submissions by unclicking the autohide empty fields box:

    But on the panel at the bottom, and in the API call, it reports a value of "1" for 1. mcc. The submissions view reports a value of "-".

    I'll send this to development so they can take a look. It might be a good idea to start a new form from scratch though. We'll update this ticket if we discover what is occurring with the data in your form.

    Thanks.

  • Profile Image
    JotForm Support

    Answered by NeilVicente on November 24, 2014 at 01:59 AM

    @dickeyad

    Checkbox items should not be sent as a single string (separated by a bar) but instead as individual object properties (with sequential keys) in JSON format.

    Thus, your request payload should be

    [{

        "1": {

            "0": "1",

            "1": "2"

        },

        "2": "1",

        "3": "1234",

        "4": "1234"

    }]

     

    OR

     

    [{"1":{ "0": "1", "1": "2"},"2":"1","3":"1234","4":"1234"}]

    ------

    Hope this helps.