Jotform conditions: My Jotform setting seem to have changed.

  • Profile Image
    Patrickdewet
    Asked on October 08, 2014 at 04:53 AM

    Hello.

    I created a form and am using it on the 'order' page of my website (www.stylehire.co.za).

    I set it up with conditions so that certain pictures and fields would only show if certain boxes or buttons were ticked.

    It now seem that ALL fields are showing regardless.

     

    Please help.

     

    Patrick

  • Profile Image
    Ben
    Answered on October 08, 2014 at 08:51 AM

    Hi Patrick,

    I took a look at your page and from what I can see it seems to be working properly now.

    As I clicked on tables and chairs I was shown different images / choices, but when none of them were selected I was not shown any image. The same happened when I unselected all choices made - all images were hidden.

    Now if the issue still persists for you please tell us the browser that you are using and we will be glad to inspect it in that browser and see if we can recreate the same issue and offer help in rectifying it.

    Best Regards,
    Ben

  • Profile Image
    Patrickdewet
    Answered on October 09, 2014 at 06:01 AM
    Hi Ben
    Thank you so much for your response.
    It seems to be working fine now.
    Thank you.
    Best regards
    Patrick de Wet
    079 894 8802
    patrick@stylehire.co.za
    Everything you need for your Perfect Event
    W: www.stylehire.co.za E: info@stylehire.co.za T: 021 705 5966 F: 086 503 2817
    Unit 34 River Park, 77 De Waal Road, Diep River, 7800 / P.O. Box 2736, Clareinch, 7740.
    ...
  • Profile Image
    Patrickdewet
    Answered on October 09, 2014 at 11:01 AM
    Hi there
    My problem still persists when using Chrome.
    Its working normally on Firefox.
    Please help.
    Thanks.
    Best regards
    Patrick de Wet
    079 894 8802
    patrick@stylehire.co.za
    Everything you need for your Perfect Event
    W: www.stylehire.co.za E: info@stylehire.co.za T: 021 705 5966 F: 086 503 2817
    Unit 34 River Park, 77 De Waal Road, Diep River, 7800 / P.O. Box 2736, Clareinch, 7740.
    ...
  • Profile Image
    ashwin_d
    Answered on October 09, 2014 at 12:00 PM

    Hello Patrick,

    Have you deleted the web page already where you have embedded your form? I did check your web page but it seems it give Page not found error. Please check the screenshot below:

    Please share the web page URL again and we will take a look.

    We will wait for your response.

    Thank you!

  • Profile Image
    Patrickdewet
    Answered on October 09, 2014 at 12:11 PM
    My apologies.
    I had made the page unavailable.
    It should be accessible now.
    Many thanks.
    Best regards
    Patrick de Wet
    079 894 8802
    patrick@stylehire.co.za
    Everything you need for your Perfect Event
    W: www.stylehire.co.za E: info@stylehire.co.za T: 021 705 5966 F: 086 503 2817
    Unit 34 River Park, 77 De Waal Road, Diep River, 7800 / P.O. Box 2736, Clareinch, 7740.
    ...
  • Profile Image
    ashwin_d
    Answered on October 09, 2014 at 12:26 PM

    Hello Patrick,

    I did test your form in chrome browser and I am unable to replicate the issue you are having. The conditions you have added to show the images seems to be working as expected. Please check the screenshot below:

    I would suggest you to test it again and get back to us if the issue persists. You may also like to let us know which of the condition is not working and we will take a look.

    We will wait for your response.

    Thank you!

  • Profile Image
    Patrickdewet
    Answered on October 13, 2014 at 08:51 AM
    Hi Ashwin
    Thank you for your comprehensive and speedy replies.
    Thank you for testing the jotform on a Chrome browser.
    The problem still persists (in different ways for different browsers) as follows:
    When viewed on my Firefox browser-
    My event is at (venue) field and all quantity fields should be hidden.
    When viewed on the Chrome browser-
    All these images and Quantity fields should be hidden.
    I have no idea why this is happening, especially as it all works fine when viewed on your website using the preview option.
    Best regards
    Patrick de Wet
    079 894 8802
    patrick@stylehire.co.za
    Everything you need for your Perfect Event
    W: www.stylehire.co.za E: info@stylehire.co.za T: 021 705 5966 F: 086 503 2817
    Unit 34 River Park, 77 De Waal Road, Diep River, 7800 / P.O. Box 2736, Clareinch, 7740.
    ...
  • Profile Image
    Patrickdewet
    Answered on October 13, 2014 at 08:51 AM
    Hi Ashwin
    Please disregard what I said about the Firefox browser below. It seems to be fine now.
    Problems with Chrome still persist.
    Thanks.
    Best regards
    Patrick de Wet
    079 894 8802
    patrick@stylehire.co.za
    Everything you need for your Perfect Event
    W: www.stylehire.co.za E: info@stylehire.co.za T: 021 705 5966 F: 086 503 2817
    Unit 34 River Park, 77 De Waal Road, Diep River, 7800 / P.O. Box 2736, Clareinch, 7740.
    Begin forwarded message:
    ...
  • Profile Image
    Ben
    Answered on October 13, 2014 at 10:04 AM

    Hi Patrick,

    When viewed on the Chrome browser-All these images and Quantity fields should be hidden.

    Would you mind telling us the browser version of your Chrome? When I take a look at it everything seems to be working properly - works just like the Firefox version.

    If you would not mind, could you please also try to do a hard refresh in your browser? To do this go to your page and then click CTRL+F5. This should clear all the items in your cache and load them once again.

    If that does not work, try clearing your Chrome browser cache completely by clicking CTRL+SHIFT+DEL.

    In case you are not able to get that settings in the Chrome browser over Mac, go to your settings (chrome://settings/) and scroll down until you find "Show Advanced Settings..." link. Click on it and then "Clear Browsing Data...".

    Do let us know if that works for you.

    Best Regards,
    Ben

  • Profile Image
    Patrickdewet
    Answered on October 13, 2014 at 10:31 AM
    Hi Ben
    I cleared browsing data as you suggested, but still no luck.
    I am using Chrome version 38.0.
    Thanks.
    Best regards
    Patrick de Wet
    079 894 8802
    patrick@stylehire.co.za
    Everything you need for your Perfect Event
    W: www.stylehire.co.za E: info@stylehire.co.za T: 021 705 5966 F: 086 503 2817
    Unit 34 River Park, 77 De Waal Road, Diep River, 7800 / P.O. Box 2736, Clareinch, 7740.
    ...
  • Profile Image
    ashwin_d
    Answered on October 13, 2014 at 11:37 AM

    Hello Patrick,

    My event is at (venue) field and all quantity fields should be hidden.

    When viewed on the Chrome browser-

    All these images and Quantity fields should be hidden.

    I am not sure if I have understood the issue you are having. I did check the conditions you have added in your form and I do not see any condition where you are hiding or showing quantity field based on the "Event" field. Please check the screenshot below:

    I would suggest you to explain the issue a bit more in detail so that we have more clarity on the issue and we will try to replicate it here. You may also like to share a screenshot of the problem. The following guide should help you in uploading image in your forum post:  https://www.jotform.com/answers/277033 

    May be I have not understood the conditions but if you say it is working on firefox but not on chrome than it must be a cache related issue. I have cleared your form cache form here. Can you please test your form again and see if the issue is resolved.

    We will wait for your response.

    Thank you!

  • Profile Image
    Patrickdewet
    Answered on October 14, 2014 at 05:21 AM
    Hi Ashwin
    I tried again on Chrome but nothing has changed.
    A lot of the fields on my form are conditional. Showing certain fields when a condition is met. It works fine when using Firefox and also when previewing on the Jotform site, so my guess is that the form is programmed correctly and that the problems are somehow related to how the various browsers handle the information.
    When using Chrome, I see this:
    etc. If you compare that to what you will see if you preview my form on your website, you will see that no images should appear when no boxes have been ticked.
    Best regards
    Patrick de Wet
    079 894 8802
    patrick@stylehire.co.za
    Everything you need for your Perfect Event
    W: www.stylehire.co.za E: info@stylehire.co.za T: 021 705 5966 F: 086 503 2817
    Unit 34 River Park, 77 De Waal Road, Diep River, 7800 / P.O. Box 2736, Clareinch, 7740.
    ...
  • Profile Image
    ashwin_d
    Answered on October 14, 2014 at 09:07 AM

    Hello Patrick,

    When you say "When using Chrome, I see this:", did you share any screenshot? We are unable to see the image you have shared.

    I would suggest you to please share the screenshot again and we will take a look. The following guide should help you upload image in forum post:  http://www.jotform.com/answers/277033 

    What I see here is: There is no image being displayed if the respective check boxes are not selected. Please check the screenshot below:

     

     

    We will wait for your response.

    Thank you!

  • Profile Image
    Patrickdewet
    Answered on October 14, 2014 at 09:41 AM
    Hi
    This was the screenshot I attached to previous email:
    Best regards
    Patrick de Wet
    079 894 8802
    patrick@stylehire.co.za
    Everything you need for your Perfect Event
    W: www.stylehire.co.za E: info@stylehire.co.za T: 021 705 5966 F: 086 503 2817
    Unit 34 River Park, 77 De Waal Road, Diep River, 7800 / P.O. Box 2736, Clareinch, 7740.
    ...
  • Profile Image
    Ben
    Answered on October 14, 2014 at 10:53 AM

    Hi Patrick,

    Unfortunately we are still not shown the screenshot. Please use the option in your toolbar to upload the image

    Also, as with my colleague, the Chrome does not show any images on the Chrome before I click on some checkbox.

    that the problems are somehow related to how the various browsers handle the information.

    JotForm is built so that all browsers display everything in the same manner. While there are some tweaks that might be needed at times, this does not usually fall under it.

    The only reason that I think would cause this would be the Chrome remembering some of the clicked options and showing you this.

    Can you please tell me the exact URL that you go to with your Chrome - are you using any prepopulating?

    Best Regards,
    Ben