What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Added SSL to site - Some form don't work now - ERR_INSECURE_RESPONSE

    Asked by product_london on October 26, 2014 at 08:48 AM

    Hi,

    I added SSL to the whole of my website a few days ago.  Now, some of the forms on my website don't work and I'm not sure why.  I'm using Chrom and checking the Javascropt console is giving this error message - Failed to load resource: net::ERR_INSECURE_RESPONSE.

    The forms that aren't working are;

    1)

    Page: https://productlondon.com/audio-mastering/upload

    Form: https://form.jotformpro.com/jsform/40413072946956

    2)

    Page: https://productlondon.com/audio-mixing/upload

    Form: https://form.jotformpro.com/jsform/40426370157955

     

    However, some forms are working ok, such as;

    1) 

    Page: https://productlondon.com/audio-mastering/pay

    Form: https://secure.jotformeu.com/jsform/40102614762343

     

    The forms are showing ok when I'm logged into my Wordpress Admin page but when logged out or checking on another computer, the form does not show.

    Page URL:
    https://productlondon.com/audio-mastering/upload

    site message jsform jotformeu secure.
  • Profile Image

    Answered by Shadae on October 26, 2014 at 10:11 AM

    Hi product_london,

    I was able to see that the two forms are not currently displaying on your website.

    After reviewing the code on your site, I am seeing that you have the form embedded in paragraph tags (<p> </p>). The issue is being caused by the tags not being closed at the correct place.

    Pages with form not showing:

    <p><script type="text/javascript" src="https://form.jotformpro.com/jsform/40426370157955"></script><br />

    <div class="alignright"><a target="_blank" href="https://productlondon.com/audio-mixing/pay/" rel="nofollow" onclick="_gaq.push(['_trackEvent', 'outbound-article-int', 'https://productlondon.com/audio-mixing/pay/', 'Next: Pay For Your Audio Mixing']);"   title="Pay For Your Audio Mixing">Next: Pay For Your Audio Mixing</a></div></p>

     

    <p><script src="https://form.jotformpro.com/jsform/40413072946956"></script><br />

    <div class="alignright"><a target="_blank" href="https://productlondon.com/audio-mastering/pay/" rel="nofollow" onclick="_gaq.push(['_trackEvent', 'outbound-article-int', 'https://productlondon.com/audio-mastering/pay/', 'Next: Pay For Your Mastering']);"   title="Pay For Your Mastering">Next: Pay For Your Mastering</a></div></p>

    Page with Form:

    <p><script type="text/javascript" src="https://secure.jotformeu.com/jsform/40102614762343"></script></p>

    <div class="alignright"><a target="_blank" href="https://productlondon.com/audio-mastering/faqs/" rel="nofollow" onclick="_gaq.push(['_trackEvent', 'outbound-article-int', 'https://productlondon.com/audio-mastering/faqs/', 'Next: Audio Mastering FAQs']);"   title="Audio Mastering FAQs">Next: Audio Mastering FAQs</a></div>

    Removing the break tags and closing the paragraph tag at the end of the embed code will resolve the issue that you are currently experiencing.

    I hope this helps! Please inform us if you need additional assistance.

  • Profile Image

    Answered by product_london on October 26, 2014 at 10:28 AM

    Thanks for your reply. I might be missing something really obvious but where can I see the code with the paragraph tags and breaks (<p></p>, </b></br>).  I'm not seeing the tags in either the visual or text tabs of Wordpress.

  • Profile Image

    Answered by Shadae on October 26, 2014 at 10:33 AM

    Hi,

    I would recommend to remove the current form embed code and embed it once again. That should resolve the issue.

    Please inform us if you need more assistance.

  • Profile Image

    Answered by product_london on October 26, 2014 at 10:57 AM

    That hasn't worked either.  I can see the form ok whilst logged into Wordpress but as soon as I log out, the form disappears.  It's the same on my Macbook or my PC and with different browsers.  I've tried clearing the cache but that hasn't worked.

  • Profile Image

    Answered by product_london on October 26, 2014 at 11:08 AM

    Also, I don't understand why this is only happening for some forms when I'm following the same process?

  • Profile Image

    Answered by product_london on October 26, 2014 at 11:21 AM

    Ok, got it working.  It was to with a caching program I was using (Quick Cache).  I deleted and installed WP Super Cache.  Deleted the cache with WP Super Cache and the forms are showing ok now.

    Thanks for helping and hopefully someone else will find this useful in the future.

  • Profile Image

    Answered by Shadae on October 26, 2014 at 11:21 AM

    Hi product_london,

    I do apologize for the issue that you are experiencing. It does appear that your site is injecting its own code.

    The best way to resolve this issue is to embed your form using the iFrame code.

    How to Get the iFrame Code

    Please inform us if you are still having an issue.

  • Profile Image

    Answered by Shadae on October 26, 2014 at 11:24 AM

    Hi,

     

    Thank you for that information! We do appreciate that update.

    Please feel free to contact us if you need further assistance.

    Thank you for using JotForm!