What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Dropbox Integration: Upload file fails when using Macintosh OSX

    Asked by coolwebs on January 03, 2015 at 08:26 PM

    Sorry, I did try to put this on another forum thread but the browser for some reason was not letting me so I decided to create a new posting so my apologies for that.

    Our College uses Jotforms to submit zipped assignment files to our dropbox from our LMS and it seems to work on PC (Mozilla and Firefox) but simply refuses for Macintosh OSX (both firefox and chrome). It comes up with an error alert and failed to upload message. I have tried 52MB files and also 7MB files, same result. Have not tried it in either Safari, IE or Opera as of yet.

    Have not gone to FTP delivery yet instead of Dropbox but are tempted to do so for whatever is more consistent and reliable.

    Some of our students have had PCs and they have reported failed uploads as well. Are there some settings I could tweak, new API to use etc?

    I know upload speed could play a role in this as in Australia we have pretty s***y internet connection speeds. Hardly many of us have T1 and the rest have ADSL where the upload speed is lucky to get above 1mbps. On top of that many of our students are attempting to use the data limit on their phones to hotspot internet connection (some have 4G, most have 3G).

    Food for though...i dunno

    Page URL:
    http://moodle.arcresources.com.au/mod/page/view.php?id=1157

    Screenshot
    JotForm dropbox uploads FTP message
  • Profile Image

    Answered by raul on January 03, 2015 at 11:05 PM

    Your post was actually entered on this thread: https://www.jotform.com/answers/135130 and I moved it to a separate thread as you may already have noticed.

    Either way, since you provided more details here. Let's use this thread to address your issue.

    Have you tried to remove the dropbox integration? Just to test if the error you're receiving is coming from the dropbox side. Also, there was a glitch with our servers that was causing errors when large files were uploaded, but the issue has been resolved.

    I also tried to check your site but it asks for a login/password to access it and also couldn't find the mentioned form in your account.

    Could you provide us the ID or URL of the embedded form so we can test it? Or maybe provide us temporary access to your site?

    We'll wait for your response.
    Thank you.

  • Profile Image

    Answered by keystoneCollege on January 04, 2015 at 04:23 AM

    http://www.jotform.co/keystoneCollege/submit

    is the direct link

    thanks for your help Raul.

     

  • Profile Image

    Answered by Ben on January 04, 2015 at 10:58 AM

    Hi,

    I would just like to confirm since the accounts usernames are different, this is actually the one and the same person/group of people?

    I not only ask this because of different usernames, but one link is referring to Academic Resource Company while the other is pointing to Keystone College.

    If not the same, @keystoneCollege please open your own thread by going here and we would be happy to assist.

    Based on the screenshot above, the issue should be resolved now as we did have a problem which was quickly resolved by our developers, but which until resolved had been showing the error shown on the screenshot.

    Best Regards,
    Ben

  • Profile Image

    Answered by ben on January 05, 2015 at 12:57 AM

    Thanks Ben & Raul,

    We are the same group and its looking better thanks.

    Cheers to the dev team too ;)

  • Profile Image

    Answered by Ben on January 05, 2015 at 08:13 AM

    Hi Ben,

    Great, thank you for the update. Do let us know however if the issue presents itself in future or if you have any further questions and we would be happy to assist.

    Best Regards,
    Ben