My jotforms are not showing up when embedded to my website

  • Profile Image
    RonEmser
    Asked on February 25, 2015 at 02:54 PM

    Okay, I have the form working correctly, but when I insert into my site the embedded forms do not show up!

    -RE

  • Profile Image
    Ben
    Answered on February 25, 2015 at 02:57 PM

    As mentioned Ron, I have moved this issue to a new thread. Now could you please give us the link to the page on your website where the jotform is added to check what is causing it to not show?

  • Profile Image
    RonEmser
    Answered on February 25, 2015 at 03:24 PM

    http://ronemser.com/test/clevectgssoc-test_011.htm

     

    Let me know. This is likely one of very few times I'll need this feature.

     

  • Profile Image
    Ben
    Answered on February 25, 2015 at 04:39 PM

    OK, I see that there are some things being loaded over HTTP protocol while your website is on HTTPS protocol (secure).

    I would suggest replacing the js embed code with the iframe embed code (but make sure that the secure option is checked when you do).

    Since you are using secure protocol for your website we will also need to change the URL of the iframe embedded forms, so:

    1. the form under

    We are now able to automatically renew your Annual CCS Membership.
    The first option below is the AUTO-RENEWAL

    should use this link:

    https://secure.jotform.us/form/50544498700154 instead of

    2. the form under

    Below is the ONE-TIME Option.

    Changed from

    http://form.jotform.us/form/50555094442151 to

    https://secure.jotform.us/form/50555094442151

    This should then show your jotforms properly.

    Do let us know how it goes.

  • Profile Image
    RonEmser
    Answered on February 25, 2015 at 05:16 PM

    Calling it a day... No success....

  • Profile Image
    Jeanette
    Answered on February 25, 2015 at 07:09 PM

    The problem I can see in your site is that you are trying to embed the form into this image

    http://ronemser.com/test/clevectgssoc-test011002.gif

    As per checking this HTML code:
    <img id="e27" name="e27" src="clevectgssoc-test011002.gif" title="" alt="clevectgssoc-test011002.gif" align="right" border="0" https://secure.jotform.us/form/50506273924151>

     

    However, it should be the opposite.

    I have made a clone of your form and I have inserted such image using our Form Designer, as a Background Page

    http://form.jotformpro.com/form/50556903386966

    The height of form can be enhanced by just dividing it into sections. In my case, I've used the page breaker (found under Survey Tools). We can keep assist you, so do not hesitate to keep asking for more help if needed.

  • Profile Image
    Jeanette
    Answered on February 25, 2015 at 07:11 PM

    Please check this particular video about background images

    http://www.jotform.com/form-designer/tuts/episode10/