What browser/platform/versions are Jotforms compatible with?

  • Profile Image
    rsvpfree
    Asked on March 22, 2015 at 06:40 AM

    Can you define which versions of which browsers are supposed to be compatible with forms created using Jotform?

  • Profile Image
    BJoanna
    Answered on March 22, 2015 at 12:24 PM

    JotFrom is compatible with all browsers//platform/versions. We are recommending to use modern browsers like Google Chrome, Firefox, Opera, Safari and Internet Explorer 11. If there is a form that does not work on a particular browser, please send us the URL of the page that has the problem and we will be glad to assist you in resolving problem. 

    Let us know if you need further assistance.