Required fields prevent user from submitting from

  • Profile Image
    jbellamy
    Asked on July 08, 2015 at 04:49 PM

    Sorry to keep adding to the conditions function which seem to get a lot of forum time, but I am having trouble with a form  in which I want the parent to be able to submit feedback for either one, two , or three kids. If they only need to submit comments from one child they should be able to get to the end on page five and hit submit. but instead they get an error message because the fields within page three and four (which are for the other two kids if needed) arent being filled out.  I tried going back to see what I used for previous forms but couldn't figure out what I'm doing wrong.

     

     

  • Profile Image
    gugnitzja
    Answered on July 08, 2015 at 04:55 PM

    I am having the same problem on my form. It used to be that if the field was not shown on the form due to conditional logic that field would not be required. Now it is requiring the field (Housing Preference) even if the condition to show the field (Division = HS or Institutes) is not true.

     

    http://www.jotformpro.com/form/40415934717961

  • Profile Image
    eee
    Answered on July 08, 2015 at 05:38 PM

    Hey,

    Problem has been solved,

    Kindest Regards,

    - Ertugrul.

  • Profile Image
    jbellamy
    Answered on July 08, 2015 at 06:48 PM

    I don't know what you did to correct it but a big Thank You! (if you can tell me that would be even greater so I won't make the mistake next time).  I have to say, of all the systems that I use on a daily basis JotForm in my book has to be given top kudos for support. I have yet to see another vendor that responds and perform solutions in the way that you guys do in terms of support. 

  • Profile Image
    EltonCris
    Answered on July 08, 2015 at 08:44 PM

    @jbellamy 

    Apologies for this inconvenience.

    It was a back-end problem so there's nothing to be changed on your end. This rises after a certain update but it has been immediately noticed and resolved. Thanks for reporting it by the way.