Free Text HTML is not saving my changes, no Edit/Complete/HTML buttons

  • Profile Image
    laurenb243
    Asked on August 10, 2015 at 10:37 AM

    I created a form and embedded it in my website.  After seeing it in action, I'd like to change the text a bit.  When I edit the form it does not seem to save the changes.  Why not?  Is it because it's already on the website?  How can I make the changes stick?

    BTW, the website is not published yet so I can't give you the URL.

    Thanks,

    Lauren

     

    Here's the link for my form: http://form.jotform.us/form/52144093210139

    When I modify it I hit the Save icon and it seems to save it, but when I preview the changes are not there.  I do not see any pop ups or error messages.

     

  • Profile Image
    Welvin
    Answered on August 10, 2015 at 12:53 PM

    Hi Lauren,

    Were you able to see the changes when you preview the form in the form builder?

    But You need to re-embed the form if you are using our source codes method (http://www.jotform.com/help/104-How-to-get-the-Full-Source-Code-of-your-Form). But if you are using our iframe or the default JS embed method, the changes should automatically reflect to the embedded form.

    If you can publish the website and share it here, that would be great so we can check it.

    Thanks

  • Profile Image
    Welvin
    Answered on August 10, 2015 at 12:58 PM

    I'm sorry, when you save the form in the form builder, did you notice some errors like popups? Or, is when you save the form, the changes doesn't appear in your website?

    If there's an error, please let us know the message or take a screenshot and post it here. If it's the changes that is not taking effect on your website, then that is because of your current embed method. Please try using our iframe method: http://www.jotform.com/help/148-Getting-the-Form-iFrame-Code.

    Thanks

  • Profile Image
    laurenb243
    Answered on August 11, 2015 at 10:21 PM

    Here's the link for my form: http://form.jotform.us/form/52144093210139

    When I modify it I hit the Save icon and it seems to save it, but when I preview the changes are not there.  I do not see any pop ups or error messages.

  • Profile Image
    laurenb243
    Answered on August 19, 2015 at 07:50 PM

    That's exactly the part of the form I want to change.  When I edit it I don't see the "Complete" icon.  What am I doing wrong when I try to edit?  I select the form from my saved forms and hit the "Edit" icon.  It brings me to my form and lets me make changes, but alas, no Complete icon so the changes are never save.

  • Profile Image
    Boris
    Answered on August 20, 2015 at 01:18 AM

    Thank you for letting us know. Do you see the Edit HTML button before you start editing the Text field?

    Please try clearing your browser cache, and see if that helps. I have also cleared your form cache just in case, though that should be unrelated.

    If the issue persists even after you've cleared your browser cache, can you also please try opening the Form Builder in another browser?

    Please let us know how it goes.

  • Profile Image
    laurenb243
    Answered on August 20, 2015 at 02:30 PM

    I tried a new browser and no difference.  Even a whole new machine so definitely no cache stored.

     

     

  • Profile Image
    laurenb243
    Answered on August 20, 2015 at 03:40 PM

    I did not see the EDIT HTML button.  Just the form and I double clicked on the text field.  It let me edit but not save.

     

  • Profile Image
    Welvin
    Answered on August 20, 2015 at 03:51 PM

    Your steps are correct and double-clicking will work as well. When you double-click the field to edit, you should see the "Complete" button as well as the "HTML" button in the toolbar:

     

    But based on your screenshot, it seems like you didn't see these buttons in the form builder. Please do the following:

    a. Assuming that you are using Google Chrome or Mozilla Firefox, press F12 in your keyboard to open the developers window.

    b. Find click the "Console" tab in the developers window.

    c. You should see some logs in the console area. If you see some logs in red color, that means there are errors in the form and that might cause you not to see the buttons. Please take a screenshot of that errors and post it here.

    I look forward to your reply.

    Thanks

  • Profile Image
    laurenb243
    Answered on August 20, 2015 at 04:24 PM

    Yes, using Chrome.  Here's the screen shot.  Hope it means more to you than it does to me!  :-)

     

  • Profile Image
    Welvin
    Answered on August 20, 2015 at 05:54 PM

    I don't see any error in the screenshot that is related to the text field. Can you try doing it again? This time, please make sure that you double-clicked the text field before checking the console tab.

    Also, try not doing the double-click method. Please do it this way instead;

    a. Click the text field

    b. Check if the "Edit HTML" button will appear. Like this:

    As you could see, the text formatting tool is not yet opened.

    So far, I still cannot replicate this to your form in Firefox and Chrome.

     

    Please try the following as well:

    a. Close the form builder

    b. Logout from your account

    c. Clear your browser's cache

    d. Clear your cookies for Jotform. 

    https://support.mozilla.org/en-US/kb/delete-cookies-remove-info-websites-stored

    https://support.google.com/chrome/answer/95647?hl=en 

    e. Login again and edit the form, still click the field and see if the Edit HTML button appears.

     

    Lastly, open the browser in safe mode (addon or extension disabled). Login and edit your form and check if it's doing the same without the button.

    Thanks

  • Profile Image
    laurenb243
    Answered on August 20, 2015 at 07:40 PM

    I did everything you suggested (except opening the browser in safe mode.  Don't know how to do that).  Nothing made a difference.  I didn't do a screen shot of the console tab because it really showed nothing.

    I tried cloning the form and same thing.  The HTML button never shows up once the form has been saved.  It is such a simple form I just re-created it the way I want it.  I may create a new account with a different username and see if that works.  It seems like I could modify the forms when I first made them but I'm not completely sure.

    I appreciate all the effort you've put on this issue.  If I ever find that I can modify a form I'll let you know.

    Thanks,

    Lauren

     

  • Profile Image
    Welvin
    Answered on August 20, 2015 at 09:08 PM

    Hi Lauren,

    Here's how to run in safe mode:

    In Firefox: https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode.

    In Google Chrome: https://support.google.com/chrome/answer/95464?hl=en

    That is just strange because I couldn't find any similar report about the Free Text HTML field.

    Maybe adding another text field will work?

    How about creating a new form and add the text field?

    But please update us here if creating a new account works and that safe mode thing.

    Thanks

  • Profile Image
    laurenb243
    Answered on August 21, 2015 at 10:59 AM

    I finally got it to work!  I tried safe mode.  Still no buttons but I happened to right click and the Complete button came up.  I went back to the normal login and found that I have to right click on the tool bar for the Complete button to display.  After that I can save it.

    Thank you so much for all your help!!

    Lauren

  • Profile Image
    Boris
    Answered on August 21, 2015 at 12:13 PM

    We are very glad to hear that you were able to get the Complete button to show. :)

    It should be visible by default as soon as the text is being edited, and we are still at a loss as to why it is not showing for you automatically, but we are glad to know that it appears for you when right-clicking on the toolbar.

    You are kindly welcome on behalf of all our colleagues. Please do not hesitate to contact us again should you experience any other issues with your forms, Lauren, we will be happy to help.