Calculation Widget not working on mobile devices

  • Profile Image
    belgllc
    Asked on October 02, 2015 at 09:30 AM

    Hello,

    I have used the calculation widget to auto-calculate total number of delegates. However on mobile devices the auto-calculation doesn't work which is preventing people from continuing to register because the "totals" field is required.

    Any way to fix this or should I simply not make the "totals" required?

     

    Thanks.

  • Profile Image
    victor
    Answered on October 02, 2015 at 11:06 AM

    Hi,

    I have tested your site with my android, and iPad device. The calculation field seems to work. Since I do not have an iPhone I have tested it in an emulator. I also notice that it is working properly.

    If you are still having issues, please let us know and we will be glad to take another look.

    Regards

  • Profile Image
    belgllc
    Answered on October 02, 2015 at 11:13 AM

    Is there something special I need to do in order for it to auto-calculate? I have tried it several times with no success. I've also had colleagues test on Android and it doesn't work.

  • Profile Image
    belgllc
    Answered on October 02, 2015 at 11:28 AM

    I actually just figured out how to get it to work using the iPhone.

  • Profile Image
    Charlie
    Answered on October 02, 2015 at 12:34 PM

    Hi,

    I checked your website at first visit and was unable to replicate the problem. However, revisiting the website caused the form calculation widget to now auto-calculate. I also noticed that you have some other issues with your form.

    Could you try the following suggestions:

    1. Add a default value on the number field or that ones you want to calculate so that the form calculation widget can auto calculate using the default "0"

     

    2. I noticed that you enabled in the advance option "wait for input before including the field in the calculation" in the Form calculation widget. This means that all the 3 fields are waiting for the user to either input a value on them or wait for the cursor to be placed in the field. Please try disabling this.

     

    3. Another suggestion is disabling the Auto Fill feature instead? This might be the one causing the problems in your end. Please do try disabling it and see if it gives you a better result. Make sure to clear your browser cache to make sure that the previous data won't conflict with the current session you have.

     

    Let us know if these steps helped.

  • Profile Image
    belgllc
    Answered on October 02, 2015 at 05:58 PM

    Thanks so much! That really helped!