What is JotForm?
JotForm is a free online form builder which helps you create online forms without writing a single line of code. No sign-up required.

At JotForm, we want to make sure that you’re getting the online form builder help that you need. Our friendly customer support team is available 24/7.

We believe that if one user has a question, there could be more users who may have the same question. This is why many of our support forum threads are public and available to be searched and viewed. If you’d like help immediately, feel free to search for a similar question, or submit your question or concern.


  • Profile Image

    Conditional Logic : Showing options for "IF" and "Field" in wrong order.

    Asked by AltoArizona on December 10, 2015 at 03:29 PM

    Hello, I am trying to create show/hide conditions for a radio button question that I have on one of my forms. When I create a condition where I want to show a specific question when "yes" or "no" is selected, I can only get it to work for one option (e.g., when "yes" is selected, it does show the question I want it to show, but when I select "no" it does not show the other question, it just disappears.

    Do you know why this might be happening and how I can fix the problem?

    Thanks.

     

    - Marco

     

    P.S. The field I'm trying to configure is "Are you working with an immigration attorney on your case?" and there are follow up questions based on whether they answer "yes" or "no."

    Page URL:
    https://form.jotform.com/53355280111950

    My Forms problem create selected
  • Profile Image
    JotForm Support

    Answered by BJoanna on December 10, 2015 at 04:46 PM

    I have inspected your form and conditions that you have set are correct, but for some reason it seems that they are not applied to "Are you working with an immigration attorney on your case?" field. Currently for that field is only applied condition if Yes is selected. 

    To fix this issue select mentioned field and add new condition if No is selected, like this.

    Here is my demo form: https://form.jotform.com/53436680537966? 

    Feel free to clone it.

    Hope this will help. Let us know if you need further assistance.

  • Profile Image

    Answered by AltoArizona on December 10, 2015 at 05:01 PM

    Thanks for your quick response. I understand your explanation but I actually do have both conditions for YES and NO. Perhaps there's a glitch with Jotform's userinterface? I don't get the wizard but the new pop up window on the right side. Please let me know how this can be fixed because I want to add several other conditions to my form...see attached screen capture.

     

  • Profile Image
    JotForm Support

    Answered by Kevin_G on December 10, 2015 at 07:02 PM

    Hi,

    You are seeing the new Conditions Wizard, and I cloned your form and I was able to replicate your issue, however, I removed them and have added them again to the form and now are working fine.

    Here is a screenshot of my conditions :

    Are the same than yours, just delete them and re-add them, it should work, here is a screencast about how is working on my end : 

    Here is the link to my cloned form : https://form.jotform.com/53437590487971? 

    You can also clone it if you want.

    Let us know if it works, if not, we will be glad to assist you.

    Thanks.

     

  • Profile Image

    Answered by AltoArizona on December 10, 2015 at 07:59 PM

    Thanks, but is still NOT working. Now when I try to delete and add the rules, the fields disappear altogether below. I can't switch to your cloned form because this form is already in use which is unfortunate because I can't make this simple function work. I have a strong feeling there is a glitch on the front end of the user interface, I've tried what you suggest and it just doesn't work.

  • Profile Image
    JotForm Support

    Answered by Kevin_G on December 10, 2015 at 10:17 PM

    Hi,

    I have checked again the conditions and I found something odd, here is what I found.

    When you are trying to set the condition, in the IF sate the option Are you working with an immigration.... is displayed with a 14| number before the name, and when you try to select the action to show the field it shows the another field with the wrong number, it should be 15| If yes, .... instead of 19| If yes, .... , here is an screenshot about what I'm talking about : 

    That is the reason why the conditions are not working properly, so I will escalate it to our second level and it will be assigned to one of our developers, you will be notified about the progress on it or when it's solved via this thread.

    Regards.

  • Profile Image

    Answered by AltoArizona on December 11, 2015 at 01:48 PM

    Kevin, YES! Thank you. I knew there was something happening beyond a simple user error. The item numbers appear very different on my end also. Here's a screen capture, FYI, it it helps any.

  • Profile Image
    JotForm Support

    Answered by BJoanna on December 11, 2015 at 03:25 PM

    Thank you for providing us a screenshot. 

    One of our developers is assigned to this issue and this ticket is marked as important. 

    Once this issue is resolved we will inform you via this thread. 

    For now with this link http://www.jotform.com/?old , you can try to access  to old conditional wizard and see if you are able to set your conditions correctly.

  • Profile Image

    Answered by Marco  on December 16, 2015 at 03:20 PM

    Hello, is there any update on troubleshooting this form?

  • Profile Image
    JotForm Support

    Answered by david on December 16, 2015 at 03:57 PM

    No updates as of yet.  I did try to replicate it in my clone and was unable to do so.  It looks like the issue may be isolated to your form.  Can you try using the conditions from this menu instead:

    http://www.jotform.com/?old

    This will load the old UI and should allow you to create conditions.

  • Profile Image
    JotForm Support

    Answered by ekrem on December 17, 2015 at 03:38 AM

    Hi Marco,

    I test it working. I created a form and cloned it to your account. Its name is 'Updated Deportation Defense Questionnaire'

    Regarding, Kevin's post:

    "I have checked again the conditions and I found something odd, here is what I found.

    When you are trying to set the condition, in the IF sate the option Are you working with an immigration.... is displayed with a 14| number before the name, and when you try to select the action to show the field it shows the another field with the wrong number, it should be 15| If yes, .... instead of 19| If yes, .... "

    For example, the following fields will not be included in 'IF statement's drop-down' but they will be in 'DO FIELD's drop-down'. Basically, 'IF statement's drop-down' will not include fields that user cannot interact.

    'Deportation Defense Questionnaire' or ' Person providing information (if different from the person detained or in immigration proceedings)'

    That's why there are more fields in 'DO FIELD's drop-down' than 'IF statement's drop-down'. So, 'Are you working with an immigration....' is displayed with a 14| number in 'IF statement's drop-down' but it is displayed with a 18| number in  'DO FIELD's drop-down'. There is no problem over there.

     

    If you have any question, please let us know.

    Regards,

     

     

     

  • Profile Image

    Answered by garzahs on January 20, 2016 at 11:06 AM

    I am having the same issue. I have more than 15 fields, and on the IF condition I am not able to see them all to select the one I need. But under the Do I can see all 25 of them. Two images provided below. Please provide fix. Thanks.

     

  • Profile Image
    JotForm Support

    Answered by BJoanna on January 20, 2016 at 12:28 PM

    @garzahs

    I have moved your question to separate thread and we will provide you an answer there shortly. 

    http://www.jotform.com/answers/750746