Signature widget will not let form submit

  • Profile Image
    spatel
    Asked on February 02, 2016 at 10:00 AM

    Good morning,

    The signature widget on my form will not let me sign.  It is just blank, and I cannot click into it with my mouse to sign.

    This issue is preventing me from submitting the form.  I tried submitting without the signature, but the button says, "Please wait..." and does not change.

    The issue appears specific to this form (https://form.jotform.com/40892890264160); I have another form with the same widget that is working fine (https://form.jotform.com/53493281630960).  

    Could you compare the two forms to see what is different?

    Additionally, this issue seems to recur for this form.  It happened about six weeks ago as well (I submitted a ticket for it).

    This issue is holding up all of my accounts payable (we rely on the form to review and approve invoices), so it has a major impact on my business.

    Best,

    Sahil

     

     

     
  • Profile Image
    david
    Answered on February 02, 2016 at 12:44 PM

    Removing the widget and replacing it with a fresh one seems to resolve the issue.  You can also try our other signature widget:

    http://widgets.jotform.com/widget/signature

    In any case, I will update your currently open ticket to see if there is any progress:

    http://www.jotform.com/answers/712996--Smooth-Signature-Widget-Blocking-form-submissions

  • Profile Image
    spatel
    Answered on February 02, 2016 at 12:57 PM

    Hi David,

    If I remove the widget, will I lose all of the data on past submissions?  That would be a major problem.

    Sahil

     
  • Profile Image
    david
    Answered on February 02, 2016 at 01:01 PM

    That is correct, you would lose the data for that field.  I sent a request for an update on your other ticket.  You may also want to request an update in that thread as well.  Sometimes tickets go unnoticed when they are dormant for a while. 

  • Profile Image
    spatel
    Answered on February 02, 2016 at 01:38 PM

    David,

    Thank you for the fast response.

    I appreciate the workaround, but it does not solve the issue.  I can't afford to lose the data (that would be a disaster) and I can't not have the form work.  I can switch to http instead of https as a workaround, but unless we get this resolved, I can't keep using jot-form.

    Best,

    Sahil

     
  • Profile Image
    david
    Answered on February 02, 2016 at 02:55 PM

    You could also clone the form and use a new copy while you are waiting for the other the be fixed.  Unfortunately, until your ticket is addressed by the developer assigned to it, there is not much else we can do.

    http://www.jotform.com/help/27-How-to-clone-an-existing-form-from-your-account